Sitemap

Amicuk Programming Answers

Azure Website deployed, but does not update

-0001-11-30   Views:0

Advertisement

Hello, I've been activly deploying changes to my Azure Website for a couple of days, has worked great. I've used both Git and WebDeploy. However, now all of a sudden it appears as if changes does not get picked up. The correct files are on the server

Hello,
I've been activly deploying changes to my Azure Website for a couple of days, has worked great. I've used both Git and WebDeploy.
However, now all of a sudden it appears as if changes does not get picked up. The correct files are on the server (checked FTP) and I see a valid "Active deployment" on the Azure portal.
But I can't see the changes (added an "X" to string in the markup of _Layout.chtml to detect it).
Any ideas here? As I said it has worked fine up til now.

The replay answer
Advertisement
We are experiencing something similar with a php Azure website. Site has been previously working correctly with GIT deployment.
Now, updating from GIT after a couple of weeks initial deployment, files confirmed to be updated by FTP.
Old files still being served from Azure, despite browser cache clearing and testing on a mobile devices browser that used 3g and had never been to the site.
The previous occasion this occurred, stopping and restarting the website fixed the problem - that's not working this time.
When the site is stopped, nothing at all is served out, so the caching is turned off with the instance.
However, when the instance is restarted, the old content is once again displayed.
It's been twelve hours now, and the old site is still being served up.
Anyone with any suggestions to resolve this?

Go to See the other 24 answers

Azure Website deployed, but does not update

Category:DefaultRelease time:-0001-11-30Views:130

Hello, I've been activly deploying changes to my Azure Website for a couple of days, has worked great. I've used both Git and WebDeploy. However, now all of a sudden it appears as if changes does not get picked up. The correct files are on the server[More]

Deployment to Azure Web App from TFS not updating

Category:DefaultRelease time:2015-10-11Views:130

Hi all, I'm having a problem with deployments to my azure web app. I'm committing my code to Visual Studio Online and then running a build to get VSO to deploy the code to Azure. The deployment seems to work fine (there are no errors that I can see)[More]

.svclog file is not creating on cloud when cloud service is deployed into azure website.

Category:DefaultRelease time:-0001-11-30Views:130

I have created a wcf cloud service which is being deployed on cloud through bitbucket repository. I want to create a .svclog file to trace logs on my azure local storage. For that, I have refered so many posts and finally configured my solution as be[More]

Cookieless session causes redirect loop when deployed to Azure Website

Category:DefaultRelease time:2015-10-11Views:130

I have a website that needs to use cookieless session. The website works fine locally and the session key gets passed into each request url as expected. However, when deployed to an Azure website, the website requests cause a redirect loop by reloadi[More]

Azure websites continues deployment using visual studio online doesn't work

Category:DefaultRelease time:-0001-11-30Views:130

Hello! I have an issue with continues deployment in Azure. I have two subscriptions for my project. I created the team project in Subscription 1 & done the automatic deployment using GITContinuesDeployment. Everything is fine but while I changed the[More]

Applicationhost.config updates for HTTP Slow Post with Azure Websites

Category:DefaultRelease time:-0001-11-30Views:130

We are trying to update our Azure websites to not show as vulnerable to the HTTP Slow Post vulnerability. Some articles suggest fixing this by updating the applicationHost.config via IIS to update the connection timeout values. Obviously with Azure w[More]

Is it possible to deploy multiple sharepoint provider hosted apps into one azure website??

Category:DefaultRelease time:-0001-11-30Views:130

Is it possible to deploy multiple sharepoint provider hosted apps into one azure website?? Rohit PasrijaI am faced with a similar requirement although the hosting environment for the provider hosted apps would be an IIS web server in our own infrastr[More]

Using AzureContinuousDeployment.11.xaml template to deploy to Azure Website not working

Category:DefaultRelease time:-0001-11-30Views:130

I have a visual studio online account and have set up continuous deployment using the AzureContinuousDeployment.11.xaml and set the Azure Website property to my publish profile, however when the build is running, it complete but never deploys. If how[More]

Windows Azure Website WCF baseAddress after Publishing to Azure

Category:DefaultRelease time:-0001-11-30Views:130

Hi! I have a WCF service, hosted on IIS, that works fantastic when not published, (localhost). If I however publish my project, (azure website, NOT cloudapp), to Azure it no longer works. I understand that there is no localhost with azure so I am ful[More]

Creation of Microsoft Azure Website failed. Cannot move or create server. Subscription ' id ' will exceed server quota.

Category:DefaultRelease time:2015-10-11Views:130

I'm trying to create a new MVC website with azure cloud server. However, when creating my project/solution in visual studio I get the following error. Creation of Microsoft Azure Website failed. Cannot move or create server. Subscription '<id>' will[More]

Best practice to use the Slot on Azure Website

Category:DefaultRelease time:2015-10-11Views:130

Hi Team, I want to understand the website slot feature little deeper. Can anyone suggest that How should we plan while we have testing, staging & production environment on Azure? (Development might be from Visual Studio Azure Emulator) Take an exampl[More]

Hot
HI, While executing the vendor & Customer ageing  Report, There is no way to give profit center in "dynamic selection button, but we have activated New gl accounting and document splitting , Is there any way to give profit center. Pl. give me gui [More]
I work with a company that does a lot of shared review of documents via PDF on their local network. I, however, am a thousand miles away, and reviewing it via a separate DropBoxed copy. It appears every time I open the DropBoxed copy of the PDF, Adob [More]
Hellow. At the beggining I had a problem. I executed runInstaller and I see :BAD Address, but I see a similar Post. I executed GNOME, in the directory /install/linux I had click over runIns.sh and !!!TA CHAN!! the installation begin. The problem is: [More]
Hello evi one .. My iphone 3gs is not charging and is not recognised by itunes .whenever i attach my iphone to my computer,it displays a message 'one of the USB devices attached to this computer has malfunctioned and windows does not recognize it ' . [More]
Hello, We have  closed the May month and started a running the business in SAP. But user saying  he wants to show the GR created in 01.01.2011 (Jan month) already closed that month. He is forcing us,  it is possible to create on back dated, make it b [More]
Hi all, There are 2 messages in the IP_IN_QUEUE. I tried to dequeue it from BPEL using the AQ Adapter, but it is not dequeing. One of the reason could be the Payload structure of the existing messages in the IP_IN_QUEUE is different from the Payload [More]
Since the last upgrade (10.0.8) Record Audio does not see the mic input to my Saffire Pro 24 DSP - the Saffire is selected as input, mono mic on Channel 1. The Saffire is working and a signal appears on its level meters and headphones. It used to wor [More]
hi, I have created one PO. At the time of Gr i have reversed it twice and third time I have posted it. All the accounting entries are correct. Now when i try to post the transport vendor invoice the amount is coming as nil. Please note that transport [More]
When using downloads I can open all current day items but when attempting to open any prior downloads then I get no response.Are you trying open from the Firefox download manager ? Because maybe you changed the directory of the download or you can tr [More]
Every time I try to sign in it will not take username and password so I have to change it and then I forget what I changed it to. Also why can't I watch videos on facebook I can with Internet Explorer Windows 7Some added toolbar and anti-virus add-on [More]