Sitemap

Amicuk Programming Answers

Caching on detailed navigation besides navigation cache?

-0001-11-30   Views:1

Advertisement

Hello Everyone, We use Btexx EasyWCM as a content management system on our SAP NW portal. When we create a new page in the portal it should appear directly in the detailed navigation, but instead it appears much much later, often after more then an h

Hello Everyone,
We use Btexx EasyWCM as a content management system on our SAP NW portal.
When we create a new page in the portal it should appear directly in the detailed navigation, but instead it appears much much later, often after more then an hour. The same happens when deleting a page.
We thought of navigation cache at first but we disabled it and the problem was still there.
Because the new page does appear after a while, what makes it time-based, we still think it might be a caching issue. We don't know what other caches influence the detailed navigation.
The page does appear in the PCD (role) directly after it is made, same goes for deletion.
We tried a restart already, but that didn't resolve anything. And I donu2019t think it's a network problem because the PCD updates instantly. Just the detailed navigation doesn't. Even when we changed the customised detailed navigation back to the standard SAP detailed navigation there was no difference.
We tried creating a page directly on the server so the caches of the proxy's etc could be excluded and the problem was still there.
Thanks.

The replay answer
Advertisement
Hello Sander,
that's good to hear. But you do not need not turn the navigation cache off.
easyWCM supports the new Navigation Cache API. If a editor changes navigation structures, easyWCM automatically invalidates the relevant roles from the cache.
Please check if your SAP Portal release and easyWCM release supports that feature.
More information are available on our support plattform:
http://www.btexx.de/support/
Best regards,
Michael

Go to See the other 4 answers

Caching on detailed navigation besides navigation cache?

Category:DefaultRelease time:-0001-11-30Views:130

Hello Everyone, We use Btexx EasyWCM as a content management system on our SAP NW portal. When we create a new page in the portal it should appear directly in the detailed navigation, but instead it appears much much later, often after more then an h[More]

Problem in loading the Portal Content Directory Structure & Detailed Naviga

Category:DefaultRelease time:2015-10-11Views:130

Hi we have installed EP6 SP16.When we are opening any tab detailed navigation is not loading.Some java sript errors are coming.Here iam pasting those errors. Please suggest asolution.logged in as super admin java script errors access denied. null or[More]

SAP Web Page Composer: Detailed Navigation is not getting built

Category:DefaultRelease time:-0001-11-30Views:130

Hello! I am new at this forum. At first I´d like to say hello to everybody! :] Our issue concerns the following: We started to work mit the Web Page Composer to build websites für our workers. Everything worked fine until the detailed WPC-navigation[More]

Adding a new link to Detailed Navigation

Category:DefaultRelease time:-0001-11-30Views:130

Hi, I have created a new iview, now I have to display this iview in MSS by providing a link in the detailed navigation of the MSS role. Can you tell me how add a new link in the detailed navigation iview ? Regards BharathYes, For finding the appropri[More]

Portal detailed navigation is missing

Category:DefaultRelease time:-0001-11-30Views:130

Hi, Gurus. Good day! I'd like to seek help from you because one of our end users reported that whenever he chose the links (which is under the portal favorites), the detailed navigation is missing. I checked with most of the users, and their detailed[More]

Open iviews in new window from detailed navigation context menu function

Category:DefaultRelease time:2015-10-11Views:130

hello, when we click in the detail navigation menu and in the context menu (because many of ours users are used to right click to open a link in a new window on the internet) on the functionnality "open in new window", the start page is always d[More]

Unable to View the contents in Detailed Navigation

Category:DefaultRelease time:2015-10-11Views:130

Hi, I have changed the IP address of the machine on which the portal server was installed to a Public IP address and from then onwards only i am facing the problem in the detailed navigation.Everything is working fine except the detailed navigation.[More]

Can't find services in the Detailed Navigation when open from Overview page

Category:DefaultRelease time:2015-10-11Views:130

Hi, We have developed a custom area page for our ESS application. The area is visible in the Overview page as well as in TLN (Top leavel navigation). When we open the area from TLN the services under this area are visible in the Detailed Navigation(D[More]

Detail Navigation missing when i link a web page in the WPC Scenario

Category:DefaultRelease time:2015-10-11Views:130

Hi to all. I had publish WPC site with the External Connector method. I have some Web Pages linked in the Navigation Structure, when i link one of this from a internal link (for example in a List link or other) I displayed the page and the detail nav[More]

Links in detailed navigation

Category:DefaultRelease time:2015-10-11Views:130

how do i add new links in the detailed navigation section? is it added in workset or page?Hi Arun, The Hierarchy of Portal object is iview, Page, workset, role. You can view application once the role is assigned to the user. If the entry point is rol[More]

How to put a web link in the detailed navigation

Category:DefaultRelease time:2015-10-11Views:130

How can you put a web link in the detailed navigation? I know that if your role contains iviews that are 3 levels down (default), then the link to the iview will appear in the detailed navigation. But, I want to put a link to a external site in the d[More]

Hot
I am just trying to fill a layer with the foreground color using the paint bucket.   I have the layer set to Normal 100% opacity and the paint bucket set to foreground 100% opacity, Normal mode. But I get zero. No color at all. The layers panel does [More]
When I click on a game, the game window opens and is solid, but when it's fully loaded, it becomes semi transparent and washed out. I can post a screen shot of what I'm talking about if this forum supports it.Hi, Please check if this happens in [http [More]
Last night, as usual, I stored my MBP asleep and went to work.  When I came home, I opened it up, and nothing happened.  I noticed that the small light on the edge of the laptop was not on.  I tried the start button; I then got a grey screen with a s [More]
I'm using a B&W G3 Mac with a PCI-MIO-16XE and a PCI NI GPIB card (don't have the model handy). I'm using the GPIB card to control a Stanford Research Systems' DS360 function generator. I can use the GPIB to control it, but when I then use the AI Acq [More]
I just upgraded from 5.0 to 6.0 and now iTunes wont open from neither shortcut, not from the c: itself. help?? should i reinstall 5.0? actually, i just realized i have version 8.2.160.0 on my drive...no idea where that one came from. should i just re [More]
Hi All, We have created a Contract/Subscription and the corresponding Rev Rec document that got posted is with fiscal/period as 0000/00. Revenue Recognition: Fiscal/Period updated as 0000/00 for a Rev rec document created after creation of a Contract [More]
Hi, I have been making a website entirely in flash CS4 AS3 and I decided to buy a contact sheet to add into it, when I added it in though it didn't work. I would click the button of the contact sheet and it didn't work. I contacted the creator if the [More]
while putting music on my ipod touch i get the account that the apparatus is in a time out after restarting, redownloading and resetting and again copying the music i still get the same error at exact 1,71 gb can anyone help me?Hey hans, Make sure yo [More]
If the camera is left on for a while, the menu button will seize to function. The camera continues to function. The only way back to the main screen is to turn off the camera. However, the menu button still won't work. The only way to get everything [More]
Hi all For my remote access password got misused by some one. Now i need to reteive new password, can any one pls help with the process satishHi vincent I got remote access from SDN, its mainly for my back  work in home. Some one has changed password [More]