Sitemap

Amicuk Programming Answers

Error loading WebappClassLoader

2015-10-11   Views:2

Advertisement

Hi All, While im trying to deploy my application using Tomcat webserver it has reported 2 errors.. 1) SEVERE: End event threw exception java.lang.reflect.InvocationTargetException at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.

Hi All,
While im trying to deploy my application using Tomcat webserver it has reported 2 errors..
1)
SEVERE: End event threw exception
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
sorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at org.apache.tomcat.util.IntrospectionUtils.callMethod1(IntrospectionUt
ils.java:890)
2)
SEVERE: Parse error in application web.xml
java.lang.IllegalArgumentException: addChild: Child name 'default' is not uniqu
e
at org.apache.tomcat.util.digester.Digester.createSAXException(Digester.
java:2719)
at org.apache.tomcat.util.digester.Digester.createSAXException(Digester.
java:2745)
at org.apache.tomcat.util.digester.Digester.endElement(Digester.java:106
0)
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.endEleme
nt(AbstractSAXParser.java:633)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImp
l.scanEndElement(XMLDocumentFragmentScannerImpl.java:1241)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImp
l$FragmentContentDispatcher.dispatch(XMLDocumentFragmentScannerImpl.java:1685)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImp
After that ive modified my web.xml "<servlet-name>default</servlet-name>" to
"<servlet-name>local_default</servlet-name>" (including the servlet mapping)
Then, i got the another 2 more errors saying that....
But i didnt got any of the previous 2 errors
1)
SEVERE: Error loading WebappClassLoader
delegate: false
repositories:
/WEB-INF/classes/
----------> Parent Classloader:
[email protected]
com.sun.xml.rpc.server.http.JAXRPCServlet
java.lang.ClassNotFoundException: com.sun.xml.rpc.server.http.JAXRPCServlet
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoa
der.java:1332)
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoa
der.java:1181)
at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.
java:1002)
at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:90
0)
2)
SEVERE: Servlet /Sampleoper threw load() exception
javax.servlet.ServletException: Wrapper cannot find servlet class com.sun.xml.rp
c.server.http.JAXRPCServlet or a class it depends on
at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.
java:1012)
at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:90
0)
at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContex
t.java:3823)
at org.apache.catalina.core.StandardContext.start(StandardContext.java:4
087)
at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase
.java:759)
at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:73
9)
Could any one resolve this problem
Any help would be appreciated
Thanks in advance
Regards
Pushpa

The replay answer
Advertisement
Are there any solution for that problem.
Jul 20, 2009 9:45:41 AM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'source' to 'org.eclipse.jst.j2ee.server:Deneme2' did not find a matching property.
Jul 20, 2009 9:45:41 AM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Program Files\Java\jre6\bin;.;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:/Program Files/Java/jre6/bin/client;C:/Program Files/Java/jre6/bin;C:\Windows\system32;C:\Windows;C:\Windows\system32\wbem;C:\Program Files\CyberLink\Power2Go;c:\Program Files\Microsoft SQL Server\90\Tools\binn;c:\Program Files\Microsoft Visual Studio 8\Common7\IDE\PrivateAssemblies;c:\Program Files\Microsoft SQL Server\90\DTS\Binn;c:\Program Files\Microsoft SQL Server\90\Tools\Binn\VSShell\Common7\IDE;C:\Program Files\QuickTime\QTSystem;C:\Program Files\Common Files\GTK\2.0\bin;C:\Program Files\MySQL\MySQL Server 5.0\bin;C:\Program Files\TortoiseSVN\bin;C:\Program Files\SSH Communications Security\SSH Secure Shell
Jul 20, 2009 9:45:41 AM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
Jul 20, 2009 9:45:41 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 388 ms
Jul 20, 2009 9:45:41 AM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Jul 20, 2009 9:45:41 AM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.16
Jul 20, 2009 9:45:42 AM org.apache.catalina.core.ApplicationContext log
INFO: Marking servlet AxisAdminServlet as unavailable
Jul 20, 2009 9:45:42 AM org.apache.catalina.core.ApplicationContext log
SEVERE: Error loading WebappClassLoader
delegate: false
repositories:
/WEB-INF/classes/
----------> Parent Classloader:
[email protected]
org.apache.axis2.transport.http.AxisAdminServlet
java.lang.ClassNotFoundException: org.apache.axis2.transport.http.AxisAdminServlet
     at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1360)
     at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1206)
     at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1083)
     at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:981)
     at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4058)
     at org.apache.catalina.core.StandardContext.start(StandardContext.java:4364)
     at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
     at org.apache.catalina.core.StandardHost.start(StandardHost.java:719)
     at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
     at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
     at org.apache.catalina.core.StandardService.start(StandardService.java:516)
     at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
     at org.apache.catalina.startup.Catalina.start(Catalina.java:578)
     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
     at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
     at java.lang.reflect.Method.invoke(Unknown Source)
     at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
     at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
Jul 20, 2009 9:45:42 AM org.apache.catalina.core.StandardContext loadOnStartup
SEVERE: Servlet /Deneme2 threw load() exception
java.lang.ClassNotFoundException: org.apache.axis2.transport.http.AxisAdminServlet
     at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1360)
     at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1206)
     at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1083)
     at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:981)
     at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4058)
     at org.apache.catalina.core.StandardContext.start(StandardContext.java:4364)
     at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
     at org.apache.catalina.core.StandardHost.start(StandardHost.java:719)
     at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
     at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
     at org.apache.catalina.core.StandardService.start(StandardService.java:516)
     at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
     at org.apache.catalina.startup.Catalina.start(Catalina.java:578)
     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
     at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
     at java.lang.reflect.Method.invoke(Unknown Source)
     at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
     at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
Jul 20, 2009 9:45:42 AM org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive axis2.war
Jul 20, 2009 9:45:42 AM org.apache.axis2.deployment.ModuleDeployer deploy
INFO: Deploying module: addressing-1.2
Jul 20, 2009 9:45:42 AM org.apache.axis2.deployment.ModuleDeployer deploy
INFO: Deploying module: soapmonitor-1.2
Jul 20, 2009 9:45:42 AM org.apache.axis2.deployment.ServiceDeployer deploy
INFO: Deploying Web service: deneme1.aar
Jul 20, 2009 9:45:42 AM org.apache.axis2.deployment.ServiceDeployer deploy
INFO: Deploying Web service: Deneme5.aar
Jul 20, 2009 9:45:42 AM org.apache.axis2.deployment.ServiceDeployer deploy
INFO: Deploying Web service: version.aar
Jul 20, 2009 9:45:43 AM org.apache.catalina.core.StandardContext addApplicationListener
INFO: The listener "listeners.ContextListener" is already configured for this context. The duplicate definition has been ignored.
Jul 20, 2009 9:45:43 AM org.apache.catalina.core.StandardContext addApplicationListener
INFO: The listener "listeners.SessionListener" is already configured for this context. The duplicate definition has been ignored.
Jul 20, 2009 9:45:43 AM org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextInitialized()
Jul 20, 2009 9:45:43 AM org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextInitialized()
Jul 20, 2009 9:45:43 AM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Jul 20, 2009 9:45:43 AM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
Jul 20, 2009 9:45:43 AM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/43 config=null
Jul 20, 2009 9:45:43 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 1527 ms

Go to See the other 4 answers

Error loading WebappClassLoader

Category:DefaultRelease time:2015-10-11Views:130

Hi All, While im trying to deploy my application using Tomcat webserver it has reported 2 errors.. 1) SEVERE: End event threw exception java.lang.reflect.InvocationTargetException at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.[More]

J2EE Packaging - Error Loading WebAppClassLoader

Category:DefaultRelease time:-0001-11-30Views:130

I have seen variations of this theme in the forum, but I am not quite sure if the solutions apply to my situation. I have a Java Web Start app deployed and sort of running on JBoss A/S. I have treated the Web Start app as a web app and the following[More]

Error message when starting Adobe Illustrator CC [Error loading plugins   AppBarControls.aip]

Category:DefaultRelease time:2015-10-11Views:130

Hello, I get the following error message when I start Adobe Illustrator CC. Error loading plugins AppBarControls.aip Then it gives me the option to continue by clicking okay. When it opens, the Application Bar is just blank. I've tried uninstalling,[More]

Having problems with Bridge shutting down after saving photo in PS Cs5,,,,,,,,,  Also when i attempt to update either PS or bridge get an error message in Adobe application manger "Error loading updater workflow"

Category:DefaultRelease time:2015-10-11Views:130

Having problems with Bridge shutting down after saving photo in PS Cs5,,,,,,,,,  Also when i attempt to update either PS or bridge get an error message in Adobe application manger "Error loading updater workflow"Sorry for the late reply. My emai[More]

Key figure definition in BEx gives "Error loading template 0QUERY_TEMPLATE"

Category:DefaultRelease time:2015-10-11Views:130

Hi, On a BI 7.0 system I try to run a query in the BEx Analyzer and after I have the result in Excel. I wants to see the key figure definition by right clicking in a data cell. Then I get this error message after the browser has started up. Error loa[More]

Cannot install Firefox. WHen I click on the link to install, it takes me to an "error loading page" notice. My network connection and internet access are normal with Internet Explorer, so this is not the issue. Some kind of conflict with my settings or pe

Category:DefaultRelease time:2015-10-11Views:130

Cannot install Firefox. When I click on the link on the Mozilla website, it goes to an "error loading page". My network connection and Internet Explorer are fuctioning normally. == computer was recently wiped clean and am now reinstalling all pr[More]

'Error loading plugin: Plugin file not found' message on ONLY 5 sites, but all others OK.  Help, please!

Category:DefaultRelease time:2015-10-11Views:130

Hi Again! I posted this problem here before, but since I really need to access the sites that receive this error message in less than a month, I had to re-post; hopefully someone who didn't see it before will see it & have a solution for me. Here are[More]

Error loading C:\Users\User Name\AppData\Local\HpWebNotifier\SyncNetOffice.dll

Category:DefaultRelease time:2015-10-11Views:130

Everytime I start up my computer I get a pop-up that states:  'Error loading C:\Users\User Name\AppData\Local\HpWebNotifier\SyncNetOffice.dll' My computer and printer work fine but this message is annoying.  I can't figure out what the problem is.  I[More]

Web UI Client - Error Loading template 0TPLB_MKTG_C01_Q0001_V01

Category:DefaultRelease time:2015-10-11Views:130

Hi Please can any one help on this below error Error Loading template 0TPLB_MKTG_C01_Q0001_V01 I have activated the Template in BI Content and able to check the same in WAD and also in RS Template Maintain in BI system. But as soon as i go to CRM Web[More]

Cannot view Crystal Report in JSP page ( error loading ? )

Category:DefaultRelease time:2015-10-11Views:130

Hi,           Can someone please help or pass on any suggestions,           I am trying to view my crystal report (test.rpt) in my JSP page but get the following error and im having trouble sorting it out. I am using Crystal 10 with weblogic. My repo[More]

After upgrade to 4.1 from 3.2, admin logon page error with "done error load

Category:DefaultRelease time:2015-10-11Views:130

Hello all, Just upgraded 3.2 to 4.1. ran @apexins.sql sysaux sysaux temp /i/. Installation was successful and upgrade completed with no errors. When trying to log on to admin page, url changes to admin workarea but with IE we get "done error loading[More]

Hot
We have added a Z field on table VBAP with an append structure. It is a flag field. We want to change its value with the BAPI BAPI_SALESORDER_CHANGE. We have also created the append structure in API structures THe return message of the bapi gives us [More]
Hi Experts, Can we set the UNIX file permissions after writing the file to a directory using Receiver File Adpater in SAP PI 7.1 ? Thanks in Advance. Regards, JyotiHi you can use the option "Run Operatiing system Command after File Processing" i [More]
Hi MM Guru's when I tried to create the PO from PR for Service Material Type (DIEN), PO price Tab is not appearing in PO can anyone let me know why this PO price tab is not coming in case of DIEN material type Thanks in Advance Priya Edited by: Priya [More]
I am trying to create an ebook in Pages. The problem I am having is in Pages my TOC shows the the title of the chapter and then dots and then the correct page number. However, when I export it as an epub and then open it any ereader it loads as: Sect [More]
I upgraded to IOS7 and now in notes I cannot change the font color, is there away to do this. I am a little fusterrated with IOS7. Just changed it over a couple of days ago.Settings > General > Accessibility ... Then choose something like "Incr [More]
I am running iWeb 1.1.2 and have published a site with seven pages. When I first open the site, running the cursor over each page title at the top "activates" it, and in Safari, the URL appears at the bottom. After I open a page or two, however, [More]
HI, I have a ce-565 conifured as a proxy . it was working fine till recently when due to spam in the network , the cpu utilisation reached 100% and i had to remove the cache engine. now whenever i put the cache engine, the network becomes slow. WIll [More]
Hi, I'm having a problem with my K8T motherboard a Kingston ValueRAM DDR400 (2x 512). I tried changing the speed, timings...nothing helps, still I got bunch of errors in Memtest. In fact, now I even cant get to BIOS with them (system halts on that Re [More]
Our router has incoming lines go to a hunt group of 4 people.  If no one picks up (i.e. school is closed) the call goes to a script in CUE that plays a welcome and gives the caller a choice of leaving a message or dialing an extension.  We would like [More]
My old profile "Klaus Tveita" had to be abandoned when I both forgot may password and no longer had access to my registered e-mail account. I established a new profile "KlausTveita" (no space) to continue skyping. Could the two mention [More]