Sitemap

Amicuk Programming Answers

Error when Import XSD file

2015-10-11   Views:0

Advertisement

Hello expert,    During creating Data Type in the build, I try to import XSD file, but system says:" XSD schema containing the construct "choice" are not permitted here"!    I found in the XSD, there are this definition:               

Hello expert,
   During creating Data Type in the build, I try to import XSD file, but system says:" XSD schema containing the construct "choice" are not permitted here"!
   I found in the XSD, there are this definition:
                              <xsd:element name="EmploymentInfo" minOccurs="0">
                                   <xsd:complexType mixed="true">
                                        <xsd:choice>
                                             <xsd:element name="FullTimeEquivalence" type="xsd:decimal"/>
                                             <xsd:element name="WorktimeInfo" maxOccurs="unbounded">
                                                  <xsd:complexType>
                                                       <xsd:sequence>
                                                            <xsd:element name="Duration" type="xsd:duration"/>
                                                            <xsd:element name="Period" type="xsd:duration"/>
                                                       </xsd:sequence>
                                                  </xsd:complexType>
                                             </xsd:element>
                                        </xsd:choice>
                                   </xsd:complexType>
                              </xsd:element>
     Could anybody tell me how to handle this? I am not quite familiar with XSD. Thanks a lot.
Best regards,
Shouxin

The replay answer
Advertisement
Hi,
replace choice with sequence
<b><xsd:complexType>
     <xsd:choice>
          <xsd:element name = “A” type=”xsd:string” />
          <xsd:element name= B” type=”xsd:string” maxOccurs=”unbounded” />
     </xsd:choice>
</xsd:complexType></b>
is handled identical to
<b><xsd:complexType>
     <xsd:sequence>
          <xsd:element name = “A” type=”xsd:string” minOccurs=”0” />
          <xsd:element name= B” type=”xsd:string”
minOccurs=”0” maxOccurs=”unbounded” />
     </xsd:sequence>
</xsd:complexType></b>
Regards
Tarun Telang

Go to See the other 2 answers

Error when Import XSD file

Category:DefaultRelease time:2015-10-11Views:130

Hello expert,    During creating Data Type in the build, I try to import XSD file, but system says:" XSD schema containing the construct "choice" are not permitted here"!    I found in the XSD, there are this definition:               [More]

Error occured while importing xsd.file(Name contains invalid characters: -

Category:DefaultRelease time:2015-10-11Views:130

Hello, i muss import xsd.file.  while importing this error occured: İFMEXTDEF CCTS_CCT_SchemaModule-2.0 | http://example.org/XXX/XXX/OUT/NOZ (SC_NOZ V001 of example.org): Name contains invalid characters: - . Only a(A)-z(Z), 0-9, and "_" are per[More]

Error while importing .xml file in Datatype

Category:DefaultRelease time:2015-10-11Views:130

Hi SDN, I am getting this error while importing .xml file in Datatype. Error when parsing the XML document (Fatal Error: com.sap.engine.lib.xml.parser.ParserException: XML Declaration not allowed here.(:main:, row:1, col:8 Actually I have created dat[More]

Error: An error occurred importing the file. Detail: File does not exist or

Category:DefaultRelease time:2015-10-11Views:130

Hi, I am getting the error the below error while importing the file in FDM. I have read and write access to the folder. I tried loading text and excel files, I am getting the same error. An error occurred importing the file. Detail: File does not exi[More]

Error while importing swf file in to Crystal Xcelsius Designer 4.5

Category:DefaultRelease time:2015-10-11Views:130

help me...., Error while importing swf file in to Crystal Xcelsius Designer 4.5I read in the book called "CRYSTAL XCELSIUS for DUMMIES" on page 243 under topic called Nesting a Dashboard within another Dashboard. sorry i used the wrong word embe[More]

Error while importing zip file for second time to B2B through ant script

Category:DefaultRelease time:2015-10-11Views:130

[echo] args=import importstatus: [echo] Commandline arguments 1: [import] [echo] Import with overwrite=true [echo] B2BCommandLineUtility: importRepository: Error messages: [echo] MDS-00521: error while reading document /soa/b2b/tpa_JOvrtiV-7030143 01[More]

Error while Importing MDL File

Category:DefaultRelease time:2015-10-11Views:130

Hi All, While Importing a MDL File, I am getting the following Error. Can someone help me asap. mport started at Apr 6, 2010 10:20:09 AM Project "PUBLIC_PROJECT" Error occurred importing from file "C:\oracle\product\10.2.0\db_2\owb\bin\admi[More]

How to import xsd file inside XSD folder in Oracle SOA 11g

Category:DefaultRelease time:2015-10-11Views:130

Hi, I need to import xsd file inside XSD folder provided by the deafult structure while creating SOA project. When I used to import the web resource it imports it inside public_html folder not inside XSD folder. How to do that ? ThanksHi, Are you usi[More]

An error occured importing the file

Category:DefaultRelease time:-0001-11-30Views:130

Hello, We are currently experiencing an issue with Importing a file that contains the Japanese Kanji character set. The error received is "Error - An error occured importing the file" The Kanji characters are only for the Descriptions within the[More]

An error occurred importing the file, although some of the file data may ha

Category:DefaultRelease time:-0001-11-30Views:130

I am trying to update some xml. I login to admin module and click on Import Exchange File. When I try to import an xml I get this error: An error occurred importing the file, although some of the file data may have been processed. ==> com.waveset.uti[More]

Error while importing WSDL file created in JDeveloper inside BS

Category:DefaultRelease time:2015-10-11Views:130

Hi All, I am facing error while importing WSDL of the DBAdapter service created using JDeveloper inside my business service in OSB. The error in OSB is 'The Resource Mapped Does not exist'Which version of OSB are you using? You need to upload schema[More]

Hot
Dear Friends, I want to generate Idocs after a sales Order delivery  status changes using workflow. Please tell me the procedure ,as i am doing this for the first time. thanks, jeevan.Suggest using "Modes" in PPM. Mode 01 will have "x" [More]
Hi, I get the above message and followed one of the links on a prior thread but when it completes the diagnostic I can not go further; http://h20000.www2.hp.com/bizsupport/TechSupport/S​oftwareIndex.jsp?cc=us&prodNameId=4023815&prodSeri​... Can yo [More]
Hello friends, Can somebody tell me what are the mandatory fields to be filled in this transaction code? please clarify my doubt regards, Sekhar_functional consultantHi kamesh, I AM DOING BDC PROGRAM FOR F-22 . but is is giving error like bdc_insert [More]
I am combining several JPEGs of identical resolution into a PDF using Preview, using either the sidebar or Automator action (http://discussions.apple.com/thread.jspa?messageID=11893607). For some reason, Preview changes the resolution of the PDF so v [More]
Hi Gurus, I have to validate infotype 0008 amount fields  in PAI user exit ZXPADU02 . For a scenario, if the amounts are not equal  ( BET01 <> BET02) then  I have to geneate error message. Then the user is supposed to correct / re-enter  the amounts [More]
Hi All, I am in need of enterprise ETL architecture in OWB 10gR2. What I mean here is, we just finished one ETL project using OWB 10gR2. Now, are heading into another project using ETL. When we sat down and design for the new system we encountered th [More]
Post Author: VeniceGlass CA Forum: Xcelsius and Live Office Even opening the application first and trying to open the 4.5 file directly, won't import.  Still getting the message, "Crystal Xcelsius is unable to load this file.  This file may be corrup [More]
Unable to update iTunes and Safari on my Macbook pro OS 10.9.5Download and run AdwareMedic: http://www.adwaremedic.com/ That should take care of it.Read other 3 answers [More]
Hi Got a new nano and want to use it with my emac. Messege is that new nano requires 10.4 or greater OS. Does anyone knows how the fix this without buying new OS for mu mac ?I'm afraid you would need to have Tiger installed, the most recent iPods req [More]
We are using XI in combination with the Seeburger adaptors I want to store the BICMAPPER Meta-Data definitions into the XI repository. So far I could not find the exact procedure to configure this. Anybody an Idee? Thanks Raf WijnendaeleHi Raf, it's [More]