Sitemap

Amicuk Programming Answers

Executable not working - Looking for LabVIEW Run-Time Engine

2015-10-11   Views:6

Advertisement

This has been one of those days. I'm trying to create my .exe file to place onto another computer. I've done this before with success. But that was then and this is now. I believe I have all the files I need in my LLB, and I believe I did my applicat

This has been one of those days.
I'm trying to create my .exe file to place onto another computer. I've done this before with success. But that was then and this is now.
I believe I have all the files I need in my LLB, and I believe I did my application distribution correctly and I believe I built the DLL correctly. But when I took the resulting .exe file and placed it on another computer and attempted to run it, it gave me the error message: "Unable to locate LabVIEW Run-Time Engine. Program requires a version 7.1 (or compatible) LabVIEW Run-Time engine. You should have already realized this, you moron."
Anyone have any idea where I went wrong or what step I might have missed? This has been a crazy, non-stop, massive brain fart of a day and I can't seem to remember what I'm missing here.
Amateur programmer for over 10 years!

The replay answer
Advertisement
Hi.
Whenever you want to use executables or .dll's created with LabVIEW you must make sure that the LabVIEW runtime engine of the SAME version as the LabVIEW version used to create the files, is installed in the target computer.
There are basically 2 ways to get the run-time engine installed on a computer:
1. (the one I prefer): Download the correct version of the LabVIEW run-time engine installer from www.ni.com/downloads, or more specifically from
http://digital.ni.com/softlib.nsf/websearch/369618​104E25B08E86256F54006A4E2F?opendocument&node=13205​0_US
for the latest one. Once you have the installer for the run-time engine, just install it in the target computer. I prefer this option because the run-time engine is installed independently, so if you then uninstall your program, the run-time engine remains.
2. Create an installer for your program that includes the run-time engine. To include the run-time engine, when you are creating your application, go to the "installer settings" tab, click on "Advanced" and make sure there is a checkmark on "include LabVIEW run-time engine". This way when you install your program in the target computer, the run-time engine will also be installed.
Just as a note, any computer with LabVIEW on it, will also have the run-time engine.
Good luck.
Alejandro

Go to See the other 7 answers

Executable not working - Looking for LabVIEW Run-Time Engine

Category:DefaultRelease time:2015-10-11Views:130

This has been one of those days. I'm trying to create my .exe file to place onto another computer. I've done this before with success. But that was then and this is now. I believe I have all the files I need in my LLB, and I believe I did my applicat[More]

Unable to locate the LabVIEW Run-Time engine

Category:DefaultRelease time:2015-10-11Views:130

Using LabVIEW 2011, I have built an executable and installer including the LabVIEW Run-Time engine. I built the app on a 32-bit system. I'm deploying it to a Windows7 64-bit system. When I ran the installer, rebooted, then tried to run the app, I got[More]

LabVIEW 2011SP1 Error building installer: LabVIEW Run-Time Engine 2013 is missing 3 dependencies???

Category:DefaultRelease time:2015-10-11Views:130

I'm having a problem building an installer in LabVIEW 2011SP1. It's been a while since I've tried to build an installer but it used to work fine and building executables is still working fine. Now when I try to build the installer I get "The build wa[More]

Teststand error states that a vi failed to load in the Labview Run-Time Engine

Category:DefaultRelease time:2015-10-11Views:130

I am getting an error in teststand that states that a vi failed to load in the Labview Run-Time Engine version '14.0.1' If I look at the software loaded on my system with the NI Measurement and Automation Explorer I have Labview Run Time engines for[More]

Unable to locate labview run time engine (lab view 8.5)

Category:DefaultRelease time:2015-10-11Views:130

Hello I have a problem whit the labview 8.5 installer. I have created I project with included a .vi file (a simple panel wich control a serial port, with parameters (baud rate, stop bits, ...)), then I have created an application for this file (.exe)[More]

Include LabVIEW Run-Time Engine in C# Project Distribution

Category:DefaultRelease time:2015-10-11Views:130

I have written a software package in Visual Studio using C# which calls a number of functions from a dll which I have built in LabVIEW. I am now trying to produce an installation program for my C# package but can't quite work out how to include the L[More]

Error -17600 when switching from LabVIEW Development System to LabVIEW Run-Time Engine in Adapter Configuration

Category:DefaultRelease time:2015-10-11Views:130

I receive an error message (code -17600) while loading my test sequence after switching from LabVIEW Development System (2009 f3) to LabVIEW Run-TIme Engine using the Adapter Configuration. ErrorCode: -17600, Failed to load a required step's associat[More]

LabVIEW Run Time Engine and ActiveX Automation Server

Category:DefaultRelease time:2015-10-11Views:130

Hi, I have a question related to LabVIEW Run Time Engine and ActiveX Automation Server: We have a tool developed in LabVIEW and TestStand. End user interface is a LabVIEW GUI (it's an executable) which executes TestStand sequences. Some TestStand seq[More]

NI 5660 Driver DLL Errors when using Teststand 2010 and LabVIEW Run-Time Engine 2010

Category:DefaultRelease time:2015-10-11Views:130

This problem seems similar to the post "Resource not found error in executable on developmen​t machine." but I didn't want to repost under that thread because I only happened upon it by chance and none of my searches brought me there... so I mad[More]

Are LabVIEW VISA functions supported by LabVIEW Run Time Engine?

Category:DefaultRelease time:-0001-11-30Views:130

I have an executable file that I created using LabVIEWS Application Builder. When I run the application on another computer that does not have LabVIEW installed, it crashes with a Windows message stateing the my application has generated erros and wi[More]

Error -18004 with LabVIEW Adapter using LabVIEW Run Time Engine 7.1.1

Category:DefaultRelease time:-0001-11-30Views:130

Hi to all, I am trying to use the LabVIEW Run Time Engine 7.1.1 instead of the Development System for executing VIs in TestStand with the LabVIEW adapter. The Problem is that I get the following error, saying that my VIs cannot be executed: -18004; A[More]

Hot
Hi team,  i have been building up native applications and has access to Microsoft tenant in azure and there i have already the mobile application. Also i can add the webapi's to my application once when i went to configure tab and hit add on the bott [More]
Hi, Im trying to create a category tile for Lumira stories with multiple search keywords. Lumira stories with single search keyword is working fine. im folling the below post Creating a category tile for SAP Lumira stories When i create dynamic conte [More]
i have a generation 1 ipod touch my wifi is not working, under setting the wifi says no wifi and is gray.  i have tried resetting it and its not workin. what should i do, please help. thanksIf a restore did not fix it, you have a hardware issue--poss [More]
Hi, i would like to know how to indicate mouse down on the 3D picture control as can be done for the picture function. http://forums.ni.com/ni/board/message?board.id=170&message.id=49423&query.id=66219#M49423 regards king1Hi King1 I have been able [More]
Has anyone got this issue. I have upgraded to new CSS, but after that my computer refuses to show login screen after wake up. It just shows the classic W7 x64 login background but that is all. Anyone is experiencing the same issue? Has anyone a copy [More]
We have many companys in the same Chart of Depreciation, but for a particular company i need to stop the account depreciation. We take a look for a exit or badi to use in transaction AFABN but we saw there aren´t. Some one know how to do that.Hello P [More]
Hello! I'm at the begin with LabView. I'd like to verify my signal with an oscilloscope. After this, when i active a light, the power of this signal must be save. I have found the oscilloscope VI. I'm tring to modify it in order to save, when it's ne [More]
Hi We have implemented MSS in EP. While running the ivew Compensation Approval (ECM), we are getting the portal run time error in the 'Adjust to Minimum' tab. Is this any configuration problem? The following is the error message we are getting. Any h [More]
Occasionally, in CS5, when I go to move a file from one folder to another in Bridge I get a message that I can't do it because I do not have sufficient permissions.  Why is Adobe scolding me in this way?  Who do I go to to these mysterious permission [More]
Hello everyone, I am looking for an opensource software for managing code .. Does anyone know any ? I have never personally used CVS but its version control? Is it like Visual Source Safe? If you have used anything .. can you tell me which ones u use [More]