Sitemap

Amicuk Programming Answers

Executable not working - Looking for LabVIEW Run-Time Engine

2015-10-11   Views:6

Advertisement

This has been one of those days. I'm trying to create my .exe file to place onto another computer. I've done this before with success. But that was then and this is now. I believe I have all the files I need in my LLB, and I believe I did my applicat

This has been one of those days.
I'm trying to create my .exe file to place onto another computer. I've done this before with success. But that was then and this is now.
I believe I have all the files I need in my LLB, and I believe I did my application distribution correctly and I believe I built the DLL correctly. But when I took the resulting .exe file and placed it on another computer and attempted to run it, it gave me the error message: "Unable to locate LabVIEW Run-Time Engine. Program requires a version 7.1 (or compatible) LabVIEW Run-Time engine. You should have already realized this, you moron."
Anyone have any idea where I went wrong or what step I might have missed? This has been a crazy, non-stop, massive brain fart of a day and I can't seem to remember what I'm missing here.
Amateur programmer for over 10 years!

The replay answer
Advertisement
Hi.
Whenever you want to use executables or .dll's created with LabVIEW you must make sure that the LabVIEW runtime engine of the SAME version as the LabVIEW version used to create the files, is installed in the target computer.
There are basically 2 ways to get the run-time engine installed on a computer:
1. (the one I prefer): Download the correct version of the LabVIEW run-time engine installer from www.ni.com/downloads, or more specifically from
http://digital.ni.com/softlib.nsf/websearch/369618​104E25B08E86256F54006A4E2F?opendocument&node=13205​0_US
for the latest one. Once you have the installer for the run-time engine, just install it in the target computer. I prefer this option because the run-time engine is installed independently, so if you then uninstall your program, the run-time engine remains.
2. Create an installer for your program that includes the run-time engine. To include the run-time engine, when you are creating your application, go to the "installer settings" tab, click on "Advanced" and make sure there is a checkmark on "include LabVIEW run-time engine". This way when you install your program in the target computer, the run-time engine will also be installed.
Just as a note, any computer with LabVIEW on it, will also have the run-time engine.
Good luck.
Alejandro

Go to See the other 7 answers

Executable not working - Looking for LabVIEW Run-Time Engine

Category:DefaultRelease time:2015-10-11Views:130

This has been one of those days. I'm trying to create my .exe file to place onto another computer. I've done this before with success. But that was then and this is now. I believe I have all the files I need in my LLB, and I believe I did my applicat[More]

Unable to locate the LabVIEW Run-Time engine

Category:DefaultRelease time:2015-10-11Views:130

Using LabVIEW 2011, I have built an executable and installer including the LabVIEW Run-Time engine. I built the app on a 32-bit system. I'm deploying it to a Windows7 64-bit system. When I ran the installer, rebooted, then tried to run the app, I got[More]

LabVIEW 2011SP1 Error building installer: LabVIEW Run-Time Engine 2013 is missing 3 dependencies???

Category:DefaultRelease time:2015-10-11Views:130

I'm having a problem building an installer in LabVIEW 2011SP1. It's been a while since I've tried to build an installer but it used to work fine and building executables is still working fine. Now when I try to build the installer I get "The build wa[More]

Teststand error states that a vi failed to load in the Labview Run-Time Engine

Category:DefaultRelease time:2015-10-11Views:130

I am getting an error in teststand that states that a vi failed to load in the Labview Run-Time Engine version '14.0.1' If I look at the software loaded on my system with the NI Measurement and Automation Explorer I have Labview Run Time engines for[More]

Unable to locate labview run time engine (lab view 8.5)

Category:DefaultRelease time:2015-10-11Views:130

Hello I have a problem whit the labview 8.5 installer. I have created I project with included a .vi file (a simple panel wich control a serial port, with parameters (baud rate, stop bits, ...)), then I have created an application for this file (.exe)[More]

Include LabVIEW Run-Time Engine in C# Project Distribution

Category:DefaultRelease time:2015-10-11Views:130

I have written a software package in Visual Studio using C# which calls a number of functions from a dll which I have built in LabVIEW. I am now trying to produce an installation program for my C# package but can't quite work out how to include the L[More]

Error -17600 when switching from LabVIEW Development System to LabVIEW Run-Time Engine in Adapter Configuration

Category:DefaultRelease time:2015-10-11Views:130

I receive an error message (code -17600) while loading my test sequence after switching from LabVIEW Development System (2009 f3) to LabVIEW Run-TIme Engine using the Adapter Configuration. ErrorCode: -17600, Failed to load a required step's associat[More]

LabVIEW Run Time Engine and ActiveX Automation Server

Category:DefaultRelease time:2015-10-11Views:130

Hi, I have a question related to LabVIEW Run Time Engine and ActiveX Automation Server: We have a tool developed in LabVIEW and TestStand. End user interface is a LabVIEW GUI (it's an executable) which executes TestStand sequences. Some TestStand seq[More]

NI 5660 Driver DLL Errors when using Teststand 2010 and LabVIEW Run-Time Engine 2010

Category:DefaultRelease time:2015-10-11Views:130

This problem seems similar to the post "Resource not found error in executable on developmen​t machine." but I didn't want to repost under that thread because I only happened upon it by chance and none of my searches brought me there... so I mad[More]

Are LabVIEW VISA functions supported by LabVIEW Run Time Engine?

Category:DefaultRelease time:-0001-11-30Views:130

I have an executable file that I created using LabVIEWS Application Builder. When I run the application on another computer that does not have LabVIEW installed, it crashes with a Windows message stateing the my application has generated erros and wi[More]

Error -18004 with LabVIEW Adapter using LabVIEW Run Time Engine 7.1.1

Category:DefaultRelease time:-0001-11-30Views:130

Hi to all, I am trying to use the LabVIEW Run Time Engine 7.1.1 instead of the Development System for executing VIs in TestStand with the LabVIEW adapter. The Problem is that I get the following error, saying that my VIs cannot be executed: -18004; A[More]

Hot
So, I signed up for Match because I wanted to upgrade my music files and replace broken, incomplete ones with clean, reliable ones from Apple.  Out of 16,660 songs in my library, only 648 weren't matched, which is just under 4%. I consider that to be [More]
no further details than I can think of. I'm not particularly technical so please keep answers simple.You're welcome Some sites automatically redirect you to a site in the local language, based on where your IP locates you. There is usually a link on [More]
Dear Experts,        I want to add one Input field in Interaction Center Webclient(IC Webclient).Is it Possible?If Possible Kindly Send me the Step by step Procedure. It is Urgent Requirement.Please Help me. Helpful Answers Will be rewarded. Regards, [More]
I have been having trouble importing photos from my camera into iPhoto for a while. Thought it may have been my old Canon PowerShot A80, but I just bought a brand new Canon Rebel XSi and I am having the same issues. Whether I use the USB cable direct [More]
My App Store app is gone from my phone and I cannot download it from Apple.com. What is my problem?If you can't find it on any of your homescreens or app folders, and you can't find it via the spotlight search screen (swipe your first home screen to [More]
Hi I am trying to prepare (i.e. tune) a Solaris 10 instance for an Oracle 10g install using a Solaris 10 project. I am new to using Solaris 10 project resource controls so I might get some of this totally wrong. I know all of the "old" kernel pa [More]
I'm not sure if this is the right folder to ask my question. I'm a BI contractor who has used a wide variety of Reporting tools but not Hyperion. I've got an opportunity that will involve using Hyperion, so I'll need to learn it. I'm having trouble i [More]
I am currently a BT ADSL customer, stats below. I know from experience with my line that I do have some REIN issues from out the house "somewhere". However, this is only a problem if the router syncs much higher than below, otherwise its a reall [More]
I bought Ligtroom 5 a few months ago as a download version. I am now running 5.3. Today I joined the Photoshop Photographer deal- LR & PS for $10 a month. Do I need to download the LR app through Creative Cloud?no, leave it.  you bought a perpetual l [More]
How come all my latest music doesn't appear in my ipod. My itunes memory for all music and my ipod memory for music is both about same amount (4.7 gb) and i have no other downloads. It doesnt matter if I resync. I don't wont to have to reset the ipod [More]