Sitemap

Amicuk Programming Answers

Form does not contain Fragments when I run it

-0001-11-30   Views:0

Advertisement

Hi Folks, I've got a form which uses fragments.This form previews fine in the designer, but when I try to run it using generatePDF Output in a process, the parts that come from the fragments are gone. The following entries are in the log: 2011-03-04

Hi Folks,
I've got a form which uses fragments.This form previews fine in the designer, but when I try to run it using generatePDF Output in a process, the parts that come from the fragments are gone.
The following entries are in the log:
2011-03-04 10:27:19,482 WARN  [com.adobe.document.XMLFormService] ALC-XTG-016-649: [1160] Error attempting to read from file
2011-03-04 10:27:19,482 WARN  [com.adobe.document.XMLFormService] ALC-XTG-029-698: [1160] InvalidSourceException Exception on URL: repository:///Header_Block_Variant2.xdp Exception: javax.ejb.EJBException: An unexpected exception occured: ALC-REP-018-000: Resource [/Header_Block_Variant2.xdp] does not exist or you do not have sufficient rights to access it.
2011-03-04 10:27:19,482 WARN  [com.adobe.document.XMLFormService] ALC-XTG-029-217: [1160] Bad value: 'Header_Block_Variant2.xdp#som($template.Header_Variant2.Header)' of the 'usehref' attribute of 'subform' element ''. Default will be used instead.
2011-03-04 10:27:19,482 WARN  [com.adobe.document.XMLFormService] ALC-XTG-029-418: [1160] XMLForm, PAexecute : 29418, Cannot resolve url: Header_Block_Variant2.xdp.
2011-03-04 10:27:22,591 INFO  [com.adobe.idp.dsc.provider.service.file.write.impl.FileResultHandlerImpl] FileResultHandlerImpl ----- preserved- source
Does anyone have any idea what the problem might be?
Thanks
Vincent

The replay answer
Advertisement
We also have an application where the fragments are stored in a subdirectory from the application. When we run that process, the serverlog show this:
2011-03-04 15:25:53,325 WARN  [com.adobe.document.XMLFormService] ALC-XTG-016-649: [1160] Error attempting to read from file
2011-03-04 15:25:53,325 WARN  [com.adobe.document.XMLFormService] ALC-XTG-029-698: [1160] InvalidSourceException Exception on URL: repository:Fragments/Header_Block.xdp Exception: javax.ejb.EJBException: An unexpected exception occured: java.lang.ClassNotFoundException: No ClassLoaders found for: com.adobe.repository.RepositoryException
2011-03-04 15:25:53,325 WARN  [com.adobe.document.XMLFormService] ALC-XTG-029-217: [1160] Bad value: '..\..\Fragments\Header_Block.xdp#som($template.Header.Header)' of the 'usehref' attribute of 'subform' element ''. Default will be used instead.
2011-03-04 15:25:53,325 WARN  [com.adobe.document.XMLFormService] ALC-XTG-029-418: [1160] XMLForm, PAexecute : 29418, Cannot resolve url: ..\..\Fragments\Header_Block.xdp.
2011-03-04 15:25:54,341 INFO  [com.adobe.idp.dsc.provider.service.file.write.impl.FileResultHandlerImpl] FileResultHandlerImpl ----- preserved- source
As you can see, the path starts with ..\..\Fragments\etc
Which I interpret as, go 2 subdirectories up and than go into the Fragmenst directory and get the fragment.
Vincent

Go to See the other 6 answers

Form does not contain Fragments when I run it

Category:DefaultRelease time:-0001-11-30Views:130

Hi Folks, I've got a form which uses fragments.This form previews fine in the designer, but when I try to run it using generatePDF Output in a process, the parts that come from the fragments are gone. The following entries are in the log: 2011-03-04[More]

Form loses fragments when I run it

Category:DefaultRelease time:-0001-11-30Views:130

Hi I've got a form which uses fragments.  This form previews fine in the designer, but when I try to run it using generatePDF Output in a process, the parts that come from the fragments are gone. The following entries are in the log: ALC-OUT-002-058:[More]

Palm software fragmented files when running Windows defragmenter

Category:DefaultRelease time:-0001-11-30Views:130

I run defragment on Windows XP and it stops at different percentage points but always shows PALM files as being fragmented. Should I completely remove the software and reinstall or is there another way around it.  I would like defragment to fully com[More]

Error while running AD User Target Recon

Category:DefaultRelease time:2015-10-11Views:130

Hi, We are getting the below error while running AD User Target Recon: [2012-09-04T10:07:32.262-04:00] [oim_server2] [NOTIFICATION] [] [oracle.iam.features.scheduler.agentry.operations] [tid: [ACTIVE].ExecuteThread: '1' for queue: 'weblogic.kernel.De[More]

JPS-01520 Error while running on Jdev 11.1.1.4

Category:DefaultRelease time:2015-10-11Views:130

Hello, I recently installed JDeveloper 11.1.1.4 (PS3) to start looking around in it. To get a better understanding of WebCenter and the new Portal set up off applications I followed an tutorial that I found on the homepage: Tutorial for Oracle WebCen[More]

Noticing a lot of database index fragmentation yet no Health Analyzer alerts...? Best practice for database maintenance in 2013?

Category:DefaultRelease time:-0001-11-30Views:130

Could someone point me to a document for best practices for database maintenance with SharePoint 2013? I have read the 2010 document, but I'm hoping their is an updated one that I'm just missing. My problem is that our DBA recently noticed that many[More]

Error while adding a new method to the Session Bean

Category:DefaultRelease time:2015-10-11Views:130

Hello everyone. I'm using jdev 11g, ejb, jpa & jsf. Everything works fine. But when I try to add a custom method to the Session Bean, I'm having an error. Here is my steps: 1) I added a new method to SessionBean.java. Something like this: public void[More]

Error while Invoking Web Service: Fusion Payables( CreateInvoiceInterface)

Category:DefaultRelease time:2015-10-11Views:130

HI, We are testing the webservice from fusion/em site but encountered with an error 'oracle.sysman.emSDK.webservices.wsdlapi.SoapTestException: Client received SOAP Fault from server : MOAC Priv Name cannot be null; Initialize MOAC" Details:- Url: Fu[More]

Reg: Error while invoking a DB Adapter in BPEL[Call a stored procedure]

Category:DefaultRelease time:2015-10-11Views:130

HI I got this Error while Tried to invoke a DB Adapter[calling a proceudre or function]. I am not able to resolve this issue. Please help me out. java.lang.Exception: oracle.sysman.emSDK.webservices.wsdlapi.SoapTestException: Client received SOAP Fau[More]

Error while deleting a custom group associated with role 'BIConsumer'

Category:DefaultRelease time:2015-10-11Views:130

Hi All, We are using OBIEE 11.1.1.6.2 and using the BISQLGroupProvider to get the groups from database tables for an user available in LDAP. I have a group named 'OBA Test Group' created in a database table. This group is linked to a user in another[More]

BPM-70830 while deploying process in BPM Composer

Category:DefaultRelease time:2015-10-11Views:130

Hi, I got these errors When I try to deploy a bpm project which created and developed in BPM Composer(11.1.1.6.0). Can anyone help me? Thanks a lot! There're already 34 processes successfully deployed with BPM Composer before this error occur, howeve[More]

Hot
Hi, I have a peculiar problem in Funds Management. As per the client requirement payment has to made in split i.e. 90% and 10% against the invoice amount raised. But, payment budget is getting updated at the time of invoice itself when i use the prof [More]
I went to MSDN to post a question to a forum on Azure, but when I click 'ask a question' it takes me here to "machine learning" instead of to "features", "pricing" etc..   Anyway, the question is this.  I had a trial version [More]
I am having trouble logging in to iMessages and FaceTime on my Mac. I read everything here and have tried a bunch of suggestions (if not all of them) in an attempt to rectify the problem. No luck. MBP 17 (late 2010), Mavericks 10.9.4 Here's what I've [More]
I'm now using Firefox 17.0.11esr in Win 7 at work and 26.0 in Win XP at home. I tried 24.2.0esr at work, but had to return to the earlier version, because of this problem below, which also happens with my home machine: I cannot save, manually or auto [More]
Ok Im a current PC user, neer usid iMac but prob buy in the next few days. I use Acronsis True Image at the moment toback up and disk image my PC so I can have a fast recovery, I like to add all my software, windows update and then do a disk image ev [More]
Hi all and sorry for presenting you with what is probably a very simply remedied problem i am experiencing.Today i purchased a Razor Naga Gaming Mouse - for that reason - gaming.  I got home and could not wait to test it out however after i had tried [More]
How to combine mutiple tracks into one album in itunes 12Make sure they all have the same Album Artist and Album Name.Read other 2 answers [More]
Hi all, can any one please say me Which is the proper transaction  to execute an invoice verification ( Evaluated receipt settlement or ERS) and how is that executed through that particular transaction.                 Regards,       Cheenangshuk das [More]
Hi, I created a smartform for RFQ.I am getting material details from EKPO.But i need RFQ quantity and delivery date to be displayed for each quantity.I found the field in structure RM06E.I tried by putting structure name in form.Its not working. Any [More]
I have previously posted re message received icon on iPhone showing red figure that mail is received but I had nothing in my inbox. This is resolved by resetting. Now I am receiving mail which says 'this message has no content' and is dated 1971! Thi [More]