Sitemap

Amicuk Programming Answers

How do you identify Contribute "browsers" from others?

-0001-11-30   Views:0

Advertisement

I'd like to show some extra information to people who are browsing a contribute capable site. E.g., having a hidden div with special edit instructions at the top of the page that only shows if the browser type is Contribute (and probably from a speci

I'd like to show some extra information to people who are
browsing a contribute capable site. E.g., having a hidden div with
special edit instructions at the top of the page that only shows if
the browser type is Contribute (and probably from a specific domain
/ ip range).
However, all my HTTP header splunking shows that Contribute
doesn't seem to supply any special identifying info. In fact the
user-agent header is the same as IE.
So, does anyone know a way to identify Contribute at the
server side?
Also, it would be nice if there was a way to have a locally
defined Contribute schema that would launch contribute from the web
browser (I know about the tool bar...). That way, authorized users
(in the web app sense) could see a link like:
<a href="contribute://site/currentURL" >Edit this page
in Contribute</a>
You could then be browsing a site with IE/Firefox/Opera and
click to edit, even if you have turned of the Contribute tool
bar.

The replay answer
Advertisement
I've checked the New pages section and for this particular
site all options are disabled for all user groups.
While it is greyed out when you just view a page it becomes
enabled when you are in edit mode.
When I'm editing an existing page in this site I can still
save a copy by using File > Actions > Publish as New Page.
Are there any other settings I should check?

Go to See the other 10 answers

How do you identify Contribute "browsers" from others?

Category:DefaultRelease time:-0001-11-30Views:130

I'd like to show some extra information to people who are browsing a contribute capable site. E.g., having a hidden div with special edit instructions at the top of the page that only shows if the browser type is Contribute (and probably from a speci[More]

Object Browsers

Category:DefaultRelease time:-0001-11-30Views:130

Has anyone out there had any luck identifying object browsers for the forte environment? I'm aware of Rational Rose' and Select' reverse engineering capability that allows the creation of inheritance diagrams. But this is a disconnected capability ba[More]

Reaching my iCloud acc on an iPad air

Category:DefaultRelease time:-0001-11-30Views:130

I bought an iPad air for my wife, how can I go to my iCloud page on Safari. Ex: If we are on a trip and I want to check my emails or look for a phone number. I tried to go to icloud.com like I do on my computer, but it wont let me. Need help, thanksY[More]

Internet browsers do not work after updating to Windows 8.1.

Category:DefaultRelease time:2015-10-11Views:130

I have spent several hours researching my issue, performing fixes that have worked for others, but to no avail. I have talked with 3rd party tech supports, in addition to Microsoft tech support. I also recently spent 3 hours under remote access with[More]

When I try to open the "Documents" folder on my toolbar it just crashes, also my web browsers crash when I try to attach documents to emails.

Category:DefaultRelease time:2015-10-11Views:130

As the title states my "Documents" folder crashes and when I try to attach documents to emails the browsers also crash. Here is my crash report Process:     Finder [1046] Path:        /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder[More]

Can I use MachineID.getBytes() or MachineID.getUniqueID() as a unique identifier?

Category:DefaultRelease time:2015-10-11Views:130

The bytes from MachineID.getBytes() are not to be treated as a unique identifier for a device.  It is unique, but is volatile and not suitable to be used as an identifier.  There are various system/hardware events which can cause the MachineID bytes[More]

Hey Guys. safari keeps crashing on my macbook retina- any ideas on how to fix this? thanks! Process:               Safari [446] Path:                  /Applications/Safari.app/Contents/MacOS/Safari Identifier:            com.apple.Safari Version:

Category:DefaultRelease time:2015-10-11Views:130

here is the crash log.. Process:               Safari [446] Path:                  /Applications/Safari.app/Contents/MacOS/Safari Identifier:            com.apple.Safari Version:               8.0.2 (10600.2.5) Build Info:            WebBrowser-76000[More]

Unable to open safari.It shows "safari quit unexpectedly" Process:               Safari [622] Path:                  /Applications/Safari.app/Contents/MacOS/Safari Identifier:            com.apple.Safari Version:               8.0.2 (10600.2.5) Build

Category:DefaultRelease time:2015-10-11Views:130

Process:               Safari [622] Path:                  /Applications/Safari.app/Contents/MacOS/Safari Identifier:            com.apple.Safari Version:               8.0.2 (10600.2.5) Build Info:            WebBrowser-7600002005000000~1 Code Type:[More]

MY BROWSERS DOESNT WORK.

Category:DefaultRelease time:2015-10-11Views:130

my mac is a mac that i had since 2009. So i opened up google chrome as always, and clicked on youtube on my tab and a page appeared that said, ERR_EMPTY_RESPONSE and whenever i open  any sites except for facebook, soundcloud and google, the page that[More]

Multiple Browsers with the same Page Flow

Category:DefaultRelease time:2015-10-11Views:130

I have a legacy application that I am working on migrating to Weblogic. The legacy application allowed the user to have multiple windows of the same module open at the same time. Users found this useful if they wanted to look at two different records[More]

Safari & all other browsers unexpectedly quite

Category:DefaultRelease time:2015-10-11Views:130

Hi Folks, We are having an issue with an iMac in our studio, that since setup (very recently, along with another identical machine which is working 100%), all the various web browers that we have installed seem to unexpectedly quit quite soon after l[More]

Hot
What's up with this? Also, once I add an invitee and hit Return, I can't delete the person.  I'm getting a question mark icon next to everybody, which is silly because AddressBook was used to make the suggestions I typed in. Running Snow Leopard 10.6 [More]
Is anybody else having trouble with using multiple output modules in after effects?  Let me elaborate:  so I'm working on a 3d film, and my worflow is to simply work with the footage side by side in a single comp (we're at HD, so the comp size is 384 [More]
I am having difficulty with the fill out and submission portion of my form creation. I have 'enabled usage rights' for reader, but for some reason when you type in the fields, the text shows up until you tab to the next field. Then the field goes bla [More]
I absolutely LOVE the iPad and Pages. When transferring Word documents to the iPad / Pages there are some frustrating incompatibilities that I hope will be corrected soon. 1) Unrecognized TimesNewRoman font is replaced with TimesNewRomanXXXX (with a [More]
I just rec'd a P10 as a gift for Christmas. Looking at the specs on the online Datasheet and elsewhere the sources say that that the P10 saves video files as .mov but the device I have can only save them as as .avi files. However the box itself does [More]
Hi, Has anyone used AQ through OCI? We are having problems with OCISubscriptionRegister() the error reported back is 'two task conversions - overflow integer'. The code we are running is straight out of the published demos... Please HELP!! Thanks, Da [More]
I have CS5 but i cannot open my RAW files. My cmera is a Nikon D3100.Hi, Nikon D3100 needs Adobe Camera raw version 6.3, in order to work with PS CS 5 Please check the ACR version on your PS CS 5 1. Open PS CS 5 2. If its Windows OS, then click help [More]
After applying Macbook Air and Macbook Pro 2.0 update, and its supplymental update, My Retina MBP ( SMC Version (system): 2.3f32 Boot ROM Version: MBP101.00EE.B02) has following problems: unable to set hibernatemode to 0: '# sudo pmset -a hibernatemo [More]
Sync has stopped working between PS Touch and Creative Cloud on my Android phone (Samsung G4). Touch is version 1.2.1, and I'm running CC and PS on my Mac under OSX Mavericks. Sync had previously worked. What happens now is that when I turn sync on i [More]
I am trying to setup HA for my three connection brokers. SQL Server I have added the instance with the login with the three connection brokers in the group on the domain and have enabled the dbcreator and public for that user login. All named pipes a [More]