Sitemap

Amicuk Programming Answers

Last argument in AGO function

-0001-11-30   Views:0

Advertisement

Hi Everyone... Hope everyone is good . So we have this requirement where user want to see selected quarter last month, then previous quarter last month and previous year last month based on Year and Quarter selection. for example. Prompts: Year - 201

Hi Everyone...
Hope everyone is good .
So we have this requirement where user want to see selected quarter last month, then previous quarter last month and previous year last month based on Year and Quarter selection. for example.
Prompts: Year - 2013; Quarter - Q2
Selected Month (1)
Last Qtr Last Month (2)
Diff of 1 - 2
Last Yr Last Month (3)
Diff of 1 - 3
Country
Jun-13
Mar-13
Qtr Diff
Dec-12
Yr Diff
USA
1000
500
500
700
300
UK
1500
900
600
1200
300
Now if user select Quarter as Q3 then report will show:
Selected Month (1) - Sep-13
Last Qtr Last Month (2) - Jun-13
Last Yr Last Month (3)- Dec-12
So the idea is to take always last month of selected last month, last qtr last month and last yr last month.
Now I am using AGO function to get the Last Yr Last Month (3) where I need to pass the last argument as a dynamic value.
AGO("measure","month","month Number")
But OBIEE say that the last argument should be a consistent integer. So is there any way where we can pass dynamic value of "Number of Period". For example
for Q1 : AGO("measure","month",3)
for Q2 : AGO("measure","month",6)
for Q3 : AGO("measure","month",9)
for Q4 : AGO("measure","month",12)
I can use CASE statement for this but will it not create performance issue, just curious?
Please help me if we can do this in this way or can you please suggest me any other way to do this.
Thanks,
Suhel Dayer

The replay answer
Advertisement
Any thoughts here.... Need help..
Appreciate your time and efforts.
Thanks....
Suhel

Go to See the other 3 answers

Hot
Hi I am displaying some rows returned from an sql querry in a dynamic page ...I hv written the sql querry between <ORACLE> AND </ORACLE> TAGS...The problem is ,i am not able to display the column names ...Why ? pl help.... ramYou must to use t [More]
Hi Gurus, We have Broadcast Messaging configured and working for CRM 5.0, ready to be transported from our Development system through to our QA system for further testing. However, when using the F4 lookup to add users to a distribution list, if we r [More]
I am attempting to install Adobe Acrobat X on a Windows 7 64 Bit machine, it will not install, gets all the way to the end and then just starts rolling back says the installation was interrupted and that no changes were made to the system. I ran the [More]
Hi, In Alv , sorting is working fine before we  selecting a row . After seleting the row , if we are  sorting it is going to dump . Dump Message: The following error text was processed in the system xxx : Adapter error in &VIEW_ELEMENT_TYPE& " [More]
Hi,  i'm ikari from indonesia,  i have 9220 curve in condition led blinking 4 times. i put my device to apploader, it says USB-PIN: UNKNOWN. i've click next, after that my phone is start to reboot again and apploader failed to connect to my device. i [More]
I do music production and my M-audio ProjectMix is a Firewire audio interface and Mbox Mini 2 don't work anymore? They're not even recognized within System Preferences.Check the manfacturers website for updated software.Read other 2 answers [More]
I'm not sure what to do.. this is really frustrating.  I never had any issues with CC.Chris, Thank you soooooo much. I would never in a million years have guessed this was the problem. As it was, it took a few hours to find the drivers, install them [More]
Hi all- We recently installed JRE 1.6.0_12 after being on an old version of JRE 1.4.2 for years. When we did this, we noticed two applications that would normally pop up a child window in front of the parent window suddenly pop up the window behind t [More]
So are school district just bought 20 iPads to give one to each of our principals and assistant principals. My outside Apple rep who was awesome was going to help me with the deployment is now fired so I need some direction on how to set them up for [More]
I have a problem with colour mismatch between Photoshop CS6 and OSX native apps such as Mail and Preview. If I calibrate my monitor (a Dell U2711) using a hardware calibrator (colormunki) and set this as the monitor profile in System Prefs the colour [More]