Sitemap

Amicuk Programming Answers

Null Values from a Data Source

2015-10-11   Views:0

Advertisement

This is more of an implementation question than a troubleshooting question. Also, since I've been unable to find any documentation on this I was wondering if anyone has come across this behavior or found a bug with it. Yesterday I was working on an a

This is more of an implementation question than a
troubleshooting question. Also, since I've been unable to find any
documentation on this I was wondering if anyone has come across
this behavior or found a bug with it.
Yesterday I was working on an application to explore some
proof of concept aspects of Flex for an application I'm developing.
I started running into a problem with Flex Data Services throwing
back an 'Unknown Property: "clientaddress1"' error whenever I tried
to update data. It seemed that whenever I tried to update a record
in the database it would thrown the Unknown Property error. I spent
a good chunk of the day trying to figure out what was causing this
and finally gave up and called it a day.
This morning I was reassessing what the problem was and
trying to find the differences between my database and my code and
I stumbled upon the fact that I could add no records and modify
them without a problem, however if I tried to access an existing
record and update it I'd get the Unknown Property error.
I start analyzing the database and found that I'd configured
the database to use null values for empty values and the records
that I created with the database had null values, however, any of
the values inserted from Flex were inserted as blank values. As
matching my action script class as clientaddress1 = ""; So, upon
further testing I fould that Flex was not processing the null
values correctly, so that when it came back and rightly generated a
Conflict Error...and then called AcceptServer() it was unable to
find the clientaddress1 property of the class.
Also, if any of the properties in the database are null it
throws the same error. Basically it seems to have invalidated the
object just because one value was null. So if all of my values from
the DB are set to something and only one field is set to null it's
still throwing the error on the first alphabetical item of the
properties.
I can resolve the problem by not using null values in the
database, but...what sort of effect would this have on someone
working with a large legacy database that extensively uses nulls
for undefined values?
Also, if a Flex guru could explain the reasoning for this
happening I would greatly appreciate it!
Best regards,
Chris Maloney

The replay answer
Advertisement
I realize that I didn't clarify that I am using ColdFusion
for getting the data. This class was generated by the Create CFC
wizard in Flex Builder.
package com.generated
[Managed]
[RemoteClass(alias="components.generated.clients.Clients")]
public class Clients
public var clientid:Number = 0;
public var clientfirstname:String = "";
public var clientlastname:String = "";
public var clientaddress1:String = "";
public var clientaddress2:String = "";
public var clientcity:String = "";
public var clientstate:String = "";
public var clientzip:String = "";
public var clientphone:String = "";
public var clientemail:String = "";
public function Clients()
}

Go to See the other 6 answers

Null Values from a Data Source

Category:DefaultRelease time:2015-10-11Views:130

This is more of an implementation question than a troubleshooting question. Also, since I've been unable to find any documentation on this I was wondering if anyone has come across this behavior or found a bug with it. Yesterday I was working on an a[More]

Unable to find data source null [Caused by: jdbc/Apps1DataSource not found]

Category:DefaultRelease time:2015-10-11Views:130

Hi, I am using OA Adapter which listens to an EBiz HRMS event, and I am encountering the following error in $Home\j2ee\oc4j_soa\log\oc4j_soa_default_group_1\oc4j\log.xml while registering the ESB service. Error details: <MSG_TEXT>Failed to process c[More]

Refresh data source view gets 'column' argument cannot be null

Category:DefaultRelease time:2015-10-11Views:130

When I try to refresh a data source view in SQL Server 2008 BIDS, I get the error: System.Data   'column' argument cannot be null.  Parameter name: column.   How to resolve this?  The underlying tables have no data yet.Hi PCSQL66, The error message s[More]

Data source value for data source reportData was null

Category:DefaultRelease time:-0001-11-30Views:130

hi i'm using struts 2 and jasperreports my problem is it generate a pdf file with labels but no data in it.. and when i try to look at the logs of my sun application server it says Data source value for datasource reportData was null. reportData is a[More]

Null pointer in Data Source deployment in WebLogic 8.1

Category:DefaultRelease time:-0001-11-30Views:130

I'm using WebLogic 8.1 in Eclipse 3.0. In the Weblogic console, my datasource tests out fine. But when I startup the WebLogic Server in Eclipse I get the error: Data Source "Datasource-Secondary" deployment failed with the following error: null.[More]

Microsoft Access Text Driver missing! and ...Cannot initialize the data source object of OLE DB provider "MSDASQL" for linked server "(null)".

Category:DefaultRelease time:-0001-11-30Views:130

In order to use OpenRowSet, I installded Microsoft Access Database Engine 2010. However, I could not find Microsoft Access Text Driver in Drivers of ODBC Data Source Administrator.  Could I get some help with that? Thank you very much!I am local admi[More]

SSRS CatalogItem method not working for deploying a shared data source

Category:DefaultRelease time:2015-10-11Views:130

I have been working with the SSRS CreateCatalogItem method to deploy reports to a SSRS 2012 in SharePoint integrated mode with SharePoint Server Enterprise 2013. I am using Powershell. The CreateCatalogItem method works fine when I deploy RDL files,[More]

Update Routine to populate 0VENDOR from either of the 2 data source fields

Category:DefaultRelease time:2015-10-11Views:130

Hi, I have a requirement to write an update routine for 0VENDOR based on the below logic : Create routines to populated BW Info Object u201CVendoru201D (0VENDOR) based on the following logic: IF field u201CVendoru201D (ITM_VENDOR_ID) is populated fro[More]

Unable to connect with new Data Source

Category:DefaultRelease time:2015-10-11Views:130

Hi everybody, After many developpment, I finally get my class to do what we need with crystal and webi report using Rebean and RAS SDK's. But, today we found a special case that I was thinking to solve following examples but the solutions given by th[More]

ADF application to access WLS data source .

Category:DefaultRelease time:2015-10-11Views:130

Hi, I have developed an ADF application in Jdeveloper 10.3.3 and deployed on Weblogic server. Now I want my application to access the data from data source created in WLS. I have created a data source (ds_demo) using the WebLoigc server option Servic[More]

Using DAO using a JDBC data source with struts

Category:DefaultRelease time:2015-10-11Views:130

Hello, I have created a number of Data Access Objects and Transfer Objects to use in a non EJB, struts web application I am developing. I had tested these with a kind of a Service Locator custom class to provide access to a JDBC connection. My custom[More]

Hot
hey ppl, new here. we have an HP 200 color M251nw that will only print black and white. Well using the black toner cartridge and not the others. I've checked the printer properties and all color sections seem enabled. I am going to try an updated dri [More]
I need help in converting thousands of .wma tracks to iTunes on my new MacBook Pro. Can anyone help me with this problem. I have a desktop at home which is IBM and my laptop is now Mac.iTunes for Windows can import WMA files, but the Mac version of i [More]
Hi all, I am problem in calling the following stored procedure. CREATE OR REPLACE PROCEDURE sp_procedure (yearVar char) AS cp char; BEGIN SELECT DISTINCT id INTO cp FROM Directory WHERE year = 'yearVar'; END sp_procedure; Calling part in my jsp page [More]
I made a form on my pc computer in Adobe Acrobat Standard XI that works without a problem, but when someone tries to open it and fill it out on a mac computer it dosen't work as it should. Is there anything I need to do with the form so that it works [More]
when setting up express devices I indicated to forget devices and now need to set them up but airport utility nolonger sees them.  how do i correct my mistakeTo set up the AirPort Express...... With an AirPort Express powered on for a few minutes, ho [More]
Hi All, I need to setup a 4 system landscape of SAP ECC 6.0 EHP4 with the SAP Baseline Package (Best Practices for Country US - V1.604). Landscape is as below: Sandbox - (1 client) - Configuration Sandbox Development - (2 clients) - Config. Master an [More]
I recently had to re-install Adobe Premiere Elements 9.0 to my new hard drive. All of a sudden I am no longer able to import AVI files. I have done this literally thousands of times in the past and now I am prevented from doing so. There is probably [More]
I'm creating a new test case. I created an applicaiton and a model project without any problems. I created the view project and add a jspx document into without anything into. I got no errors when compiling. I added a adf table by dropping an iterato [More]
I'm just getting started with creating my own lab view classes using the class object but I'm having trouble with some of the basic concepts. Are there any good tutorials or knowledge base articles which talk about how to create and use LabVIEW class [More]
I know that I can have two browser windows, each showing a different project; I want to have two browsers windows for SAME project. Is there a way to do this?Can't be done as far as I know. Here's a link to some tips on multiple tabs in Aperture. htt [More]