Sitemap

Amicuk Programming Answers

Org.apache.axis2.AxisFault: samples.quickstart.service.axiom.StockQuoteServ

-0001-11-30   Views:0

Advertisement

I am trying to run the axiom StockQuoteService sample as provided in the axis2-1.2 download. the AXIOMClient.java runs fine under tomcat 6.x and jre 6.x on my PC. After that I try to deploy the StockQuoteService.aar file on the tomcat running in a so

I am trying to run the axiom StockQuoteService sample as provided in the axis2-1.2 download. the AXIOMClient.java runs fine under tomcat 6.x and jre 6.x on my PC.
After that I try to deploy the StockQuoteService.aar file on the tomcat running in a solaris m/c. The version of tomcat, jre are the same. I matched all the axis2*.jars and the axiom-*.jars in the axis2/lib and tomcat/lib. I am able to have the access to the services page (http://<ip>:8080/axis2/services.., and display the wsdl file for the StockQuoteService using the URL.
But When I try to use the service using the AXIOMClient.java, it gives the following exception:
[java] send getPricePayload: <tns:getPrice xmlns:tns="http://quickstart.samples/xsd"><tns:symbol>WSO</tns:symbol></tns:getPrice>
[java] send updatePayload: <tns:update xmlns:tns="http://quickstart.samples/xsd"><tns:symbol>WSO</tns:symbol><tns:price>123.42</tns:price></tns:update>
[java] done
[java] org.apache.axis2.AxisFault: samples.quickstart.service.axiom.StockQuoteService
[java] at org.apache.axis2.util.Utils.getInboundFaultFromMessageContext(Utils.java:434)
[java] at org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:373)
[java] at org.apache.axis2.description.OutInAxisOperationClient.execute(OutInAxisOperation.java:294)
[java] at org.apache.axis2.client.ServiceClient.sendReceive(ServiceClient.java:520)
[java] at org.apache.axis2.client.ServiceClient.sendReceive(ServiceClient.java:500)
[java] at samples.quickstart.clients.AXIOMClient.main(AXIOMClient.java:73)
[java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[java] at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
[java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
[java] at java.lang.reflect.Method.invoke(Unknown Source)
[java] at org.apache.tools.ant.taskdefs.ExecuteJava.run(ExecuteJava.java:217)
[java] at org.apache.tools.ant.taskdefs.ExecuteJava.execute(ExecuteJava.java:152)
[java] at org.apache.tools.ant.taskdefs.Java.run(Java.java:764)
[java] at org.apache.tools.ant.taskdefs.Java.executeJava(Java.java:218)
[java] at org.apache.tools.ant.taskdefs.Java.executeJava(Java.java:132)
[java] at org.apache.tools.ant.taskdefs.Java.execute(Java.java:105)
[java] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
[java] at sun.reflect.GeneratedMethodAccessor1.invoke(Unknown Source)
[java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
[java] at java.lang.reflect.Method.invoke(Unknown Source)
[java] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
[java] at org.apache.tools.ant.Task.perform(Task.java:348)
[java] at org.apache.tools.ant.Target.execute(Target.java:357)
[java] at org.apache.tools.ant.Target.performTasks(Target.java:385)
[java] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
[java] at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
[java] at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
[java] at org.eclipse.ant.internal.ui.antsupport.EclipseDefaultExecutor.executeTargets(EclipseDefaultExecutor.java:32)
[java] at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
[java] at org.eclipse.ant.internal.ui.antsupport.InternalAntRunner.run(InternalAntRunner.java:423)
[java] at org.eclipse.ant.internal.ui.antsupport.InternalAntRunner.main(InternalAntRunner.java:137)
Both the client and the server code is unchanged. The application runs fine on my PC but gives the above error on the solaris m/c. Can somebody give me some pointers what to look for?
Thanks in advance
Deepak

The replay answer
Advertisement
I am also facing the same problem. can any body help us?
Thanks
jaya

Go to See the other 2 answers

Org.apache.axis2.AxisFault: samples.quickstart.service.axiom.StockQuoteServ

Category:DefaultRelease time:-0001-11-30Views:130

I am trying to run the axiom StockQuoteService sample as provided in the axis2-1.2 download. the AXIOMClient.java runs fine under tomcat 6.x and jre 6.x on my PC. After that I try to deploy the StockQuoteService.aar file on the tomcat running in a so[More]

Exception (org.apache.axis2.AxisFault: Server) when accessing Web-Service

Category:DefaultRelease time:2015-10-11Views:130

Hi all, I have read already some interesting posts on Java implementation for Oracle CoD Web Services. Somehow I am stuck and can't find a way out. I try to access the LeadQuery command via the following code:           String sessionCookie = logon([More]

Org.apache.axis2.AxisFault: The service cannot be found for the endpoint

Category:DefaultRelease time:-0001-11-30Views:130

Hi Team, I'm getting following error while runnig WebServices [ERROR] The service cannot be found for the endpoint reference (EPR) /TestServices/services org.apache.axis2.AxisFault: The service cannot be found for the endpoint reference (EPR) /TestSe[More]

Apache.axis2.AxisFault: com.ctc.wstx.exc.WsUnexpCharExcep: Unexpted char ""

Category:DefaultRelease time:-0001-11-30Views:130

Dear All, I amfacing the following Exception when trying to call a web service to contact, i generated stubs using Apache axis2-1.5.4 and am using eclipse Galelio org.apache.axis2.AxisFault: com.ctc.wstx.exc.WstxUnexpectedCharException: Unexpected ch[More]

Exception in thread "main" org.apache.axis2.AxisFault: Error in extracting

Category:DefaultRelease time:-0001-11-30Views:130

I am getting this exception when I call the web service from the client. Please help me here. Exception in thread "main" org.apache.axis2.AxisFault: Error in extracting message properties      at org.apache.rampart.handler.RampartSender.invoke(R[More]

Exception in thread "main" org.apache.axis2.AxisFault: Exception occurred w

Category:DefaultRelease time:-0001-11-30Views:130

Hi, My webservice is public List getRes(int a, int b) throws Exception { List list = new ArrayList(); list.add("ddd"); list.add("ddd"); list.add("ddd"); System.out.println(list); return list; I am using axis2 code generator t[More]

Crm OnDemand error -- org.apache.axis2.AxisFault: Client

Category:DefaultRelease time:-0001-11-30Views:130

Hi, I am having some problem with the Administrative Services Web service of crm Ondemand . I want to Read the CustomRecordTypes from my crm instance through the web services. I have downloaded the WSDL for that from the crm sites Administrative Serv[More]

Bad Archive return org.apache.axis2.AxisFault: Deserialisation failed

Category:DefaultRelease time:-0001-11-30Views:130

We tried to generate stub using Axis2-1.5 tool from SAP WSDL file. We developed the Java client to consume the Web Services with Stub. When we tried to connect and send the required data received the following error. Bad Archive return org.apache.axi[More]

Org.apache.axis2.AxisFault: Read timed out

Category:DefaultRelease time:-0001-11-30Views:130

We have web service client generated from wsdl2jave of axis2-1.4.1, we are getting an error on calling webservice operation,  i have manually set timeout at one of the operation invocation, that looks fine now, but we have call so many places, do i n[More]

Org.apache.axis2.AxisFault: namespace mismatch require

Category:DefaultRelease time:-0001-11-30Views:130

hello Friends, I am doing an Axis2 WebService, i have done every thing like created .arr, Depoyed , i have generated stub , i wrote client every thing is working fine but when i run my client it is showing the following error. org.apache.axis2.AxisFa[More]

Axis2.AxisFault: Connection aborted by peer

Category:DefaultRelease time:-0001-11-30Views:130

Hi, I developed a web service cliente using axis2 but I'm getting this error: org.apache.axis2.AxisFault: recv failed: Connection aborted by peer Does anyone know what this means? thanks in advance, Manuel LeiriaBijush.p.Jose <[email protected],com>[More]

Hot
I have several apps that I've downloaded that I know are free 100% and even ones I've had for years, but since updating to a whole new phone, things aren't acting right. Every time I try to update these apps, I get this thing where I have to sign in [More]
Hello there. I am new to Macbook Pro's and iPad 2's. I bought this here Macbook Pro about a month ago. I bought a new iPad 2 Wi-Fi 16GB yesterday from Best Buy. I'm not very "computery". I provide live sound (I run sound / mix bands) for a livng [More]
I just switched to a new Mac and now I have songs in my Itunes library that will not authorize.  They were fine on my cloud and last computer?  How can I solve this? I used Migration assistant to transfer files.  It's always worked for me in the past [More]
Hi, My goal is to eliminate a usage of namespace when sending a SOAP message, i.e. do not write 'xmlns:n1="http://some_namespace"' in the root element of inner <Body> element. [My web service contains a handlers-chain that gets SOAP messag [More]
I have a HP Officejet 8500 printer/scanner/fax and since I've upgraded to Lion OS X 10.7.5 I can no longer scan from my computer like I did previously.  I don't know if it was a previous version of Lion or Snow Leopard.  If I can downgrade from 10.7. [More]
I have eXchange 2010 on Hyper V for delivering email sitting on Server 2008 R2 I am able to send outgoing mail but I am not receiving anything from outside: this is for all accounts.Hi do you have a receive connector setup? Anonymous access enabled o [More]
My libraries panel is missing from the window dropdown. Where else can I access it? Is that normal?Lisa, You may try the list (or go straight to 6) if you have updated to Yosemite without reinstalling). The following is a general list of things you m [More]
I've had my droid for almost a year now and am very happy with it, but recently i've been having a few issues. Today it turned itself off in the middle of a phone call, my fingers were not near any button to cause this, and when I turned it back on I [More]
My iphone works perfectly with my router but shows up with the device name "unknown" Can I name it? so that the router will the name I give to it? just as it does other devices connected to it. I have named it in the bluetooth settings so if som [More]
Hello I've a folder on my Mac with about 3500 pictures in it - I'd like to re-export all those pictures from Aperture - what I was wondering is whether there is a way to basically create a file list with all the pictures in that specific folder on th [More]