Sitemap

Amicuk Programming Answers

OVM Manager 3.1.1 can't discover one of the servers

-0001-11-30   Views:14

Advertisement

Hi, I have a weird problem with one of our OVM3 servers. Due to "System is initializing ..." errors I had to delete and recreate the OVM Manager DB. The operation went smoothly but after a restart I'm only able to discover one of the servers (so

Hi,
I have a weird problem with one of our OVM3 servers. Due to "System is initializing ..." errors I had to delete and recreate the OVM Manager DB. The operation went smoothly but after a restart I'm only able to discover one of the servers (soaovm2). We actually have each of the servers in a separate pool (self-tough best practice if you plan to use RAC on the VMs). So, as mentioned the second server was discovered just fine (with pool and everything) but the first server is refusing to get discovered:
Job Construction Phase
begin()
Appended operation 'Discover Manager Server Discover' to object 'OVM Foundry : Discover Manager'.
commit()
Completed Step: COMMIT
Objects and Operations
Object (IN_USE): [DiscoverManager] OVM Foundry : Discover Manager
Operation: Discover Manager Server Discover
Job Running Phase at 15:48 on Tue, Jun 11, 2013
Job Participants: []
Actioner
Starting operation 'Discover Manager Server Discover' on object 'OVM Foundry : Discover Manager'
Setting Context to model only in job with id=1370965683697
Operation 'NTP Service Configure' in non-job running context, not adding it to object 'e4:11:5b:ac:b1:10:e4:11:5b:ac:b1:10:e4:11:5b:ac'.
Operation 'NTP Service Configure' in non-job running context, not adding it to object 'e4:11:5b:ac:b1:10:e4:11:5b:ac:b1:10:e4:11:5b:ac'.
Operation 'Server Set Statistic Interval' in non-job running context, not adding it to object 'e4:11:5b:ac:b1:10:e4:11:5b:ac:b1:10:e4:11:5b:ac'.
Job Internal Error (Operation)com.oracle.ovm.mgr.api.exception.FailedOperationException: OVMAPI_4010E Attempt to send command: discover_hardware to server: e4:11:5b:ac:b1:10:e4:11:5b:ac:b1:10:e4:11:5b:ac failed. OVMAPI_4004E Server Failed Command: discover_hardware , Status: org.apache.xmlrpc.XmlRpcException: I/O error while communicating with HTTP server: The server 57.56.168.171 failed to respond
Tue Jun 11 15:48:08 UTC 2013
Tue Jun 11 15:48:08 UTC 2013
at com.oracle.ovm.mgr.action.ActionEngine.sendCommandToServer(ActionEngine.java:507)
at com.oracle.ovm.mgr.action.ActionEngine.sendUndispatchedServerCommand(ActionEngine.java:459)
at com.oracle.ovm.mgr.action.ActionEngine.sendServerCommand(ActionEngine.java:385)
at com.oracle.ovm.mgr.action.ActionEngine.sendDiscoverCommand(ActionEngine.java:308)
at com.oracle.ovm.mgr.action.ServerAction.getHardwareInfo(ServerAction.java:104)
at com.oracle.ovm.mgr.discover.ovm.ServerHardwareDiscoverHandler.query(ServerHardwareDiscoverHandler.java:206)
at com.oracle.ovm.mgr.discover.ovm.ServerHardwareDiscoverHandler.query(ServerHardwareDiscoverHandler.java:42)
at com.oracle.ovm.mgr.discover.ovm.DiscoverHandler.execute(DiscoverHandler.java:61)
at com.oracle.ovm.mgr.discover.DiscoverEngine.handleDiscover(DiscoverEngine.java:461)
at com.oracle.ovm.mgr.discover.DiscoverEngine.handleDiscover(DiscoverEngine.java:446)
at com.oracle.ovm.mgr.discover.DiscoverEngine.handleDiscover(DiscoverEngine.java:430)
at com.oracle.ovm.mgr.discover.DiscoverEngine.handleDefaultDiscover(DiscoverEngine.java:391)
at com.oracle.ovm.mgr.discover.DiscoverEngine.discoverNewServer(DiscoverEngine.java:377)
at com.oracle.ovm.mgr.discover.DiscoverEngine.discoverServer(DiscoverEngine.java:280)
at com.oracle.ovm.mgr.op.manager.DiscoverManagerServerDiscover.action(DiscoverManagerServerDiscover.java:48)
at com.oracle.ovm.mgr.api.collectable.ManagedObjectDbImpl.executeCurrentJobOperationAction(ManagedObjectDbImpl.java:1012)
at com.oracle.odof.core.AbstractVessel.invokeMethod(AbstractVessel.java:329)
at com.oracle.odof.core.AbstractVessel.invokeMethod(AbstractVessel.java:289)
at com.oracle.odof.core.storage.Transaction.invokeMethod(Transaction.java:826)
at com.oracle.odof.core.Exchange.invokeMethod(Exchange.java:245)
at com.oracle.ovm.mgr.api.manager.DiscoverManagerProxy.executeCurrentJobOperationAction(Unknown Source)
at com.oracle.ovm.mgr.api.job.JobEngine.operationActioner(JobEngine.java:218)
at com.oracle.ovm.mgr.api.job.JobEngine.objectActioner(JobEngine.java:309)
at com.oracle.ovm.mgr.api.job.InternalJobDbImpl.objectCommitter(InternalJobDbImpl.java:1140)
at com.oracle.odof.core.AbstractVessel.invokeMethod(AbstractVessel.java:329)
at com.oracle.odof.core.AbstractVessel.invokeMethod(AbstractVessel.java:289)
at com.oracle.odof.core.BasicWork.invokeMethod(BasicWork.java:136)
at com.oracle.odof.command.InvokeMethodCommand.process(InvokeMethodCommand.java:105)
at com.oracle.odof.core.BasicWork.processCommand(BasicWork.java:81)
at com.oracle.odof.core.TransactionManager.processCommand(TransactionManager.java:773)
at com.oracle.odof.core.WorkflowManager.processCommand(WorkflowManager.java:455)
at com.oracle.odof.core.WorkflowManager.processWork(WorkflowManager.java:513)
at com.oracle.odof.io.AbstractClient.run(AbstractClient.java:42)
at java.lang.Thread.run(Thread.java:662)
Caused by: com.oracle.ovm.mgr.api.exception.IllegalOperationException: OVMAPI_4004E Server Failed Command: discover_hardware , Status: org.apache.xmlrpc.XmlRpcException: I/O error while communicating with HTTP server: The server 57.56.168.171 failed to respond
Tue Jun 11 15:48:08 UTC 2013
at com.oracle.ovm.mgr.action.ActionEngine.sendAction(ActionEngine.java:798)
at com.oracle.ovm.mgr.action.ActionEngine.sendCommandToServer(ActionEngine.java:503)
... 41 more
End of Job
from Agent log:
[2013-06-11 15:40:24 5177] DEBUG (OVSCommons:124) get_api_version: ()
[2013-06-11 15:40:24 5177] DEBUG (OVSCommons:132) get_api_version: call completed.
[2013-06-11 15:40:24 5178] DEBUG (OVSCommons:124) discover_server: ()
[2013-06-11 15:40:25 5178] DEBUG (OVSCommons:132) discover_server: call completed.
[2013-06-11 15:40:28 5335] DEBUG (OVSCommons:124) discover_hardware: ()
[2013-06-11 15:40:28 5336] DEBUG (OVSCommons:124) discover_hardware: ()
[2013-06-11 15:40:28 5337] DEBUG (OVSCommons:124) discover_hardware: ()
[2013-06-11 15:40:28 5338] DEBUG (OVSCommons:124) discover_hardware: ()
I have tried every possible trick there is (delete discover_hardware.lock, delete agent db) as well as made sure communication works ok both ways (can connect to soaovm1:8899 from manager as well as ovmmgr:7001 from server, passwords double-checked) but nothing helps. I still get the same error. My suspicion is this has something to do with the one-node cluster pool the server is (was?) in. It seems to be working ok but I can't stop it:
[[email protected] ~]# /etc/init.d/o2cb status
Driver for "configfs": Loaded
Filesystem "configfs": Mounted
Stack glue driver: Loaded
Stack plugin "o2cb": Loaded
Driver for "ocfs2_dlmfs": Loaded
Filesystem "ocfs2_dlmfs": Mounted
Checking O2CB cluster "6d707b8abd12b5af": Online
  Heartbeat dead threshold: 31
  Network idle timeout: 60000
  Network keepalive delay: 2000
  Network reconnect delay: 2000
  Heartbeat mode: Global
Checking O2CB heartbeat: Active
  0004FB0000050000DBE4AF6EF63C7A3A /dev/dm-11
Nodes in O2CB cluster: 0
[[email protected] ~]# /etc/init.d/o2cb stop
Clean userdlm domains: OK
Stopping global heartbeat on cluster "6d707b8abd12b5af": Failed
o2cb: Heartbeat region in use while stopping heartbeat on region '0004FB0000050000DBE4AF6EF63C7A3A'
I would appreciate any ideas here (preferably ones which wouldn't require rebooting guest VMs ...) as I have no clue what to try next.

The replay answer
Advertisement
I ran into this issue.  The fix for me was to restart the ovm manager (so on the ovm manager I ran "/etc/init.d/ovmm restart") and then I restarted the ovs-agent on the host. So I did "/etc/init.d/ovs-agent restart".
If you need to you can reset the ovs agent password from the host by issuing "ovs-agent-passwd oracle <password>".
Hope this helps.
~Bryan

Go to See the other 2 answers

OVM Manager 3.1.1 can't discover one of the servers

Category:DefaultRelease time:-0001-11-30Views:130

Hi, I have a weird problem with one of our OVM3 servers. Due to "System is initializing ..." errors I had to delete and recreate the OVM Manager DB. The operation went smoothly but after a restart I'm only able to discover one of the servers (so[More]

OVM Manager 3.2.1 fail to discover Oracle VM for SPARC 3.0

Category:DefaultRelease time:-0001-11-30Views:130

tail -f /var/log/ovs-agent.log [2013-03-05 17:06:20 3785] DEBUG (service:76) call start: get_api_version [2013-03-05 17:06:20 3785] DEBUG (service:76) call complete: get_api_version [2013-03-05 17:06:20 3786] DEBUG (service:76) call start: discover_s[More]

Ops Center 12c - discovery of OVM Manager fails

Category:DefaultRelease time:-0001-11-30Views:130

Ops Center 12c - discovery of OVM Manager fails I am trying to discover OVM Manager and the OC job fails, I noticed that its trying to connected using port 54321 which only listens to localhost. is there any way to change Ops Center discovery to use[More]

Oracle vm manager 3.3.1 can't discover the server which one has reinstall system

Category:DefaultRelease time:2015-10-11Views:130

           It couldn't to import the iso file to the Repositories,and I doubt that the nfs  which it created by the disks of ovm server has some problem .So the ovm server has reinstalled system.            There's the log from the  ovm server on /va[More]

Adding an OVM server back into OVM Manager after a reload

Category:DefaultRelease time:-0001-11-30Views:130

We have created a sandbox environment to test Oracle virtualization and had 2 physical servers setup. One running Oracle OVM and the other Oracle Linux. The Oracle Linux box had OVM Manager installed and was using local storage for the repository. Af[More]

Unable to Boot OVM Manager ISO from iLOM

Category:DefaultRelease time:-0001-11-30Views:130

Hi all, I am trying to boot the OVM Manager ISO on a Fire X4150 using the console redirection but all that comes up is "Grub" and allows no further interaction. I've tried downloading the ISO multiple times, using an older version of the OVM ins[More]

Does OVM Manager require access to SAN/NAS VLAN

Category:DefaultRelease time:-0001-11-30Views:130

Hello everyone, In our setup OVM Manager is installed on its own physical server, using for storage the local disk. Does the storage discovering process requires OVM Manager to have access to the SAN/NAS VLAN, or is this going through the OVM Servers[More]

OVM Server Ownership in OVM Manager

Category:DefaultRelease time:-0001-11-30Views:130

Hi, I am new to OVM so go easy on me ;) Am having a play around with OVM 3 for the first time. I managed to get into a state in OVM Manager where my OVM Server was kind of half discovered, although I was able to "Take Ownership" in the Manager.[More]

OVM manager 3.0.3.546 locked up with message "Please wait while system is initializing"

Category:DefaultRelease time:-0001-11-30Views:130

Hi , I am receiving this message on any actions on OVM manager. and AdminServer.log with this message ####<Aug 16, 2013 9:26:16 AM EST> <Warning> <com.oracle.ovm.mgr.model.ModelEngine> <serverneame> <AdminServer> <Odof Tcp[More]

Lost connection between ovm-manager and ovm-server (ovm 3.1)

Category:DefaultRelease time:2015-10-11Views:130

Hi, I have a manager as a VM on my laptop and a physical server as an ovm-server. Everything is fine when i boot the server but after some time, the manager stop to show the information from the server. in the ovs-agent log file the following message[More]

How to start virtual OVM Manager and restore server pool which hosts it?

Category:DefaultRelease time:2015-10-11Views:130

It had to happen... the day I migrate our OVM Manager from an ESX host into an Oracle VM, we have a massive NetApp outage, and everything fails to come back. As a result of having lock errors when trying to start any VMs I noted on the forum various[More]

Hot
One of the messages I get says "Now that you've got Firefox 4, learn about all the cool things you can do with your new browser" There are several other little messages that also show up plus the "restart previous session" box. I just [More]
Hello. I am trying to develop a VI for an FPGA target and I'm trying to make it so whoever is using the VI can specify the size of an input array when they instantiate it (such as by having an input to the VI that says "max array size" or someth [More]
Mplayer currently doesn't seem to handle the growing files. They are usually used when you stream something from the web (e.g. youtube-dl). Now when mplayer reaches the offset which was the size at the open time it just quits with various errors. Her [More]
Hi, Presently my Query output is as follows : CurrPair     Buy Curr     Sale Curr     Amount(USD) USD/INR       USD       INR       100 USD/INR       INR       USD       125 We have to take the Absolute value of the difference of both the Amounts and [More]
Hi all I have two dropdownlistbox. When I select an item in the first box,according to the selection, I have to add items in the second dropdownlistbox. I want the implementation of the onClientSelect="javascript:Sample();" of the first dropdown [More]
Hi All, Could you please help me in installing ORACLE TEXT in Oracle 10g. What exactly ils this feature and how I can install it. Regards Harpreet SinghYou don't need the companion CD to install Oracle Text. Oracle Text is installed by default if you [More]
Hi Gurus, Do you know if there is a way not to display the adress and the bank account number of a vendor let's say in the transaction FB60 ? Thanks ! JPThat is phishing attack Someone, other then Apple, sent it to you Read http://support.apple.com/k [More]
JDev 11.1.1.3, MySql 5.1, Windows 7 x64 When you place a search panel with a table using view criteria on a page the search does not function properly. The search criteria is developed as shown in the VO: ( (UPPER(Patients.card_number) LIKE UPPER( :p [More]
'm experiencing low playback performance on fcpx 10.1.2 on my new mac pro: I'm on a 8-core, 64GB, d700 (project and files are all on the main drive. Im on the latest maverick update. Im working on prores 1080p and adding some effects to a clip and my [More]
I have searched several threads regarding the permission prerequisites for SCCM installation but have not found one that cleary addresses my question. I have setup the appropriate permissions with the SCCM computer accounts and site installation serv [More]