Sitemap

Amicuk Programming Answers

Problem with dblink through ODBC

-0001-11-30   Views:0

Advertisement

Hi. Our company are trying to connect to an Oracle 7.3.4 database from Oracle 10g through an ODBC link (using Microsoft Oracle ODBC driver). The database link is working when we test it in SQL Plus, meaning that select * from [email protected] is

Hi. Our company are trying to connect to an Oracle 7.3.4 database from Oracle 10g through an ODBC link (using Microsoft Oracle ODBC driver). The database link is working when we test it in SQL Plus, meaning that select * from [email protected] is working. But, when we are using
Select count(*)
from [email protected] we get an error:
SQL> select count(*) from [email protected];
ERROR:
ORA-28500: forbindelse fra ORACLE til ikke-Oracle-system returnerte denne
meldingen:
[Generic Connectivity Using ODBC][Microsoft][ODBC driver for Oracle]Error in
row 1[Microsoft][ODBC driver for Oracle]Error in column 1: Numeric value out of
range (SQL State: 01S01; SQL Code: 0)
ORA-02063: foran 2 lines fra TEST_SID
no rows selected
SQL>
Why is this happening when the tatabase link is working with regular selects?
We think that the problem is centered around the odbc and db link settings. Could it be that we need to specify more in the HS init file? This is our file initTEST_SID.ora:
# HS init parameters
HS_FDS_CONNECT_INFO = odbc_test
HS_AUTOREGISTER = TRUE
HS_FDS_TRACE_LEVEL=OFF
HS_DB_NAME = hsodbc
# Environment variables required for the non-Oracle system
#set <envvar>=<value>
Could it be the ODBC driver version? Our MS ODBC driver is:
Microsoft ODBC for ORacle version 2.575.1022.00, MSORCL32.DLL
Has anybody experienced something like this before?
Ronny

The replay answer
Advertisement
I tried the same thing when we needed to connect a 9i database to a 7.3.4 database, but could not get it to work.
Instead, we used a database link to an 8i database which had a database link to our 7.3.4 database. We had to set up some views on the 8i database to hide the link, but it was only temporary. If you go down this route, check your licensing situation.
Tak

Go to See the other 2 answers

Problem with dblink through ODBC

Category:DefaultRelease time:-0001-11-30Views:130

Hi. Our company are trying to connect to an Oracle 7.3.4 database from Oracle 10g through an ODBC link (using Microsoft Oracle ODBC driver). The database link is working when we test it in SQL Plus, meaning that select * from [email protected] is[More]

Query update on each iteration problem (MS SQL Sever / ODBC / Native Driver

Category:DefaultRelease time:2015-10-11Views:130

Hello, I�ve been working to learn some Java and now JDBC over the past 10 or so months. I think I have a general understanding of how to perform queries and work with data using JDBC. However, I�ve run into a problem. I�m trying to do a query of a se[More]

Problem with dblink in Oracle Forms 6i

Category:DefaultRelease time:2015-10-11Views:130

I hava a problem and i try to compile a form that use a dblink when i start to compile the form the IDE is close and no errors are shown. That someone know what can i do for it ??... The Dblink is defined like this way: sqlstr := 'SELECT ' || The_Col[More]

Problem in building JDBC ODBC connection with my stand alone Project.

Category:DefaultRelease time:2015-10-11Views:130

Hello Everyone! I gave the following command in order to create JAR file: C:\app>jar cvfm MyJar.jar Manifest.txt . and the Manifest file contains the code: Main - Class: Login My Manifest File and the .class codes and the JAR file which is created su[More]

Urgent! Problems with bridge JDBC-ODBC

Category:DefaultRelease time:-0001-11-30Views:130

Hello, I have found out that JDBC-ODBC bridge in JDK 1.4.1 don't works fine, because, if you want to store text largest 254 characters in a field type text in one record of a Access database's table, it generate a SQLError, I have tried with EasySoft[More]

Any problem with dblinks between 8.1.7 and 10gR2?

Category:DefaultRelease time:-0001-11-30Views:130

Hi, Just want to know if any of you have encountered problem using a dblink between an Oracle database 8.1.7 and a brand new 10.2? I guess simple query from the 8i db to 10gR2 data would be OK...or not!? But what for queries with joins??? Many Thanks[More]

Problem with connecting [Microsoft][ODBC Driver Manager]

Category:DefaultRelease time:2015-10-11Views:130

I am employing the Apache Tomcat 5.5.During the time of execution one Exception occur which implies [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified In ordinary way of execution of DataBase connectivity(with[More]

Problem connecting through with ODBC driver

Category:DefaultRelease time:2015-10-11Views:130

I have a virtual machine (Win XP SP3) running Oracle 11.1.0.7.0. The name of the machine is UK010862.uk.int.**********.com. sqlnet.ora: SQLNET.AUTHENTICATION_SERVICES= (NTS) NAMES.DIRECTORY_PATH= ( TNSNAMES, EZCONNECT) tsnames.ora: ORCL = (DESCRIPTIO[More]

Performance problem with dblink

Category:DefaultRelease time:-0001-11-30Views:130

Hi! I have 2 servers with a dblink join. I push from server A to server B with an insert sentence 80 mb of data (blob datatype). It take between 4 to 5 hours to insert. Server A and B are in the same office. (Windows 2000) Somebody have an idea why i[More]

Problem in DBLINK | More Inactive sessions

Category:DefaultRelease time:-0001-11-30Views:130

Hello All, We are facing some problem in our environment due to db links between the applications 1. MYDB and TSTDB applications reside on two different DB's. 2. MYDB has a db link to TSTDB to extract data from TSTDB. 3. There are lot of sessions cre[More]

Getting a problem while using Microsoft ODBC for Oracle

Category:DefaultRelease time:-0001-11-30Views:130

Oracle(tm)Client and networking components not found. These components are supplied by Oracle Corporation and part of Oracle Version 7.2 or greater Client software installation. You will be unable to use this driver until these components have been i[More]

Hot
I've just recently connected the Airport Extreme to my iMAC G4. I understand that it should work with my Windows laptop. I've set up the base station and do have a connection on my laptop with excellent "signal strength" and the speed, at best, [More]
Hi. Today I was preparing to use my Ipod Touch when all on it's own, it powered off. When I restarted it, it came back on and I noticed that some of the setting's(date & time) were no longer as they had been when I previously set them. Other settings [More]
Hi. Please advice how to build a network where the different computers can interact and be seen.Since your question is extremely broad and lacking in detail... In simple terms, get a router and connect the computers to the router. Enable file sharing [More]
This might be a bug, but I'm hoping it's just a config file problem. I have a few files here and there on my NTFS drive that have Japanese characters in their filenames.  Sometime recently (I don't have an exact date when they disappeared), they stop [More]
Hello, I am new to scripting and trying to find a way to search for a supposed virus file named wsr[any two numbers]zt32.dll on a large group of computers. I'm not sure how or where to use Get-ChildItem -Path C:\Users -Filter ?zt32.dll -Recurse | exp [More]
Have a new iMac g5 with Tiger. Want to copy over files from older PowerMac running 9.1, using firewire Target Disc mode. Didn't work. Tried reverse (using iMacG5 as target disc) and it corrupted that disc. With Apple's help, erased/reformatted iMac G [More]
hi all, i installed oracle 10g r2 in my machine. os is windows XP. in E:\oracle\product\10.2.0\db_1\sysman\emd\upload location every day lot of files are generated and consume lot of memory. i want to know what is the reason for this files and how to [More]
Hi, I am configuring BizTalk 2013 in a Virtual machine and SQL server 2012 in another Virtual machine.  I have successfully configured the SSODB database. while configuring the Group's i am getting following error. " exception of type System.Enterpri [More]
This is driving me nuts. I'm building an HTML application for my iPad, but I can't make it play .wav files which are returned from either a Java servlet or an ASP handler (I'm sure I'm setting the "content-type" correctly - "audio/wav" [More]
I used to successfully mount my Arch desktop drives on my Ubuntu laptop, using NFS. Recently I switched my laptop (which is my production machine for work) to Arch as well. Since the desktop is configured as the NFS server, I assumed it was simply a [More]