Sitemap

Amicuk Programming Answers

Read/write problem with Datasockets.

-0001-11-30   Views:0

Advertisement

Hi, I'm a newcomer to Labview, and I'm having a problem with Datasockets. When trying to create a 'Publish & Subscribe' socket between two machines it only works on one, the one whose dstp address is the local machine, the other being incapable of wr

Hi, I'm a newcomer to Labview, and I'm having a problem with Datasockets. When trying to create a 'Publish & Subscribe' socket between two machines it only works on one, the one whose dstp address is the local machine, the other being incapable of writing to this 'host' and displaying red LEDs, although it is reading from the host. Also I've only managed to set up these read/write connections using the right-click options, how is it done programatically? Any clarification on the issue (whether directly connected or not :-) would be appreciated. Many thanks,
Tom

The replay answer
Advertisement
Hi Lector!
This is normal behavior for DataSocket. You want to run a DataSocket server on both machines. Although you can SUBSCRIBE to a DS server anywhere on the network, you can only publish to your local server. We do a LOT of Datasocket work here, and this has never been a problem. It's a real security bonus, as well.
It's a good idea to split all your read and write functions. Although some front panel objects (knobs, particularly) can be controls and indicators simultaneaously, it's good practice, for a number of reasons, to NOT use both functions. I build "dummy" front panels for all my VI's which I distribute to all my colleagues who need to work with a remote instrument.
You cannot really appreciate DataSocket, till you've tried to rem
otely control something with PC Anywhere over a slow network! A bit of practice, and you'll wonder how you ever did anything without DataSocket. I'd be glad to work with you on any particulars. Good Luck!
Eric
Eric P. Nichols
P.O. Box 56235
North Pole, AK 99705

Go to See the other 4 answers

Read/write problem with Datasockets.

Category:DefaultRelease time:-0001-11-30Views:130

Hi, I'm a newcomer to Labview, and I'm having a problem with Datasockets. When trying to create a 'Publish & Subscribe' socket between two machines it only works on one, the one whose dstp address is the local machine, the other being incapable of wr[More]

Problem with Datasocket

Category:DefaultRelease time:-0001-11-30Views:130

While transfering data using datasocket it showing an error 1182(Error in parsing DataSocket URL). What is the reason for this error. After execution data socket server is shoeing information about datatransfer(ie. no of packet received, no of packet[More]

Datasocket - OPC Problem

Category:DefaultRelease time:-0001-11-30Views:130

Hello I have a problem with Datasocket, when I try to read from the "NI OPC Servers", I can't. But, if I execute the program with the option "Highlight Execution", there are not problems. I've already tried to put a "Wait" be[More]

Labview for Linux. Datasocket problem

Category:DefaultRelease time:-0001-11-30Views:130

Hello everybody, I have a problem using datasocket connections in Labview for Linux. The problem is the starting of the connection, it's too slow. It takes around 3 or 4 seconds each connection. We are working with a lot of connections (one per Tag i[More]

Cluster and DataSocket

Category:DefaultRelease time:-0001-11-30Views:130

Hi there, I´ve a problem with DataSocket and Clusters containing several variables (Strings, boolean Array and Numerics) . One PC aquires data (DataSocket server). The other PC connects as client to the DS server and indicates the data. The problem i[More]

OPC with datasocket/itools

Category:DefaultRelease time:-0001-11-30Views:130

Hi, I have a problem with Datasocket and Dasylab 8.0 when using OPC to talk to Eurotherm PID controllers using the Eurotherm OPC server.  Dasylab sends out a 0 when the worksheet is first run and then the correct variable value. This causes problems[More]

Error 42 : Datasocket Read Function

Category:DefaultRelease time:-0001-11-30Views:130

Hello, I have a problem about DataSocket Read Function . I want to read some data from OPC server. I read data and its value 100  as seen in picture dOPCexplorer . But when I give a start Labview .exe as seen Santral Veri Kayıt.vi, I get error 42 abo[More]

DataSocket+OPC+Siemens=can't add item.

Category:DefaultRelease time:-0001-11-30Views:130

I'm working on different OPC servers and I'm able to connect to most of them without a problem (using DataSockets as well as OPC Data Access Automation Interface v.2.02). So, my DataSocket example works fine for National Instruments OPC servers,and I[More]

Why the speaker cannot play rhe recived wave file from data socket?

Category:DefaultRelease time:-0001-11-30Views:130

hi, i have problem with datasocket when reading a sound file recieved from another computer,at the reciever side we have a waveform at the input of the sowrite module but nothing plays from speaker. thanks in advance banner,Hello! I am facing a simil[More]

Does call to ptsname() cause memory leak?

Category:DefaultRelease time:-0001-11-30Views:130

Purify signalled that the call to ptsname() is a memory leak. ptsname() returns a char* and apparently is doing this on the heap even though the man page says it is a static data area. My question is whether we need to do a free() on the return from[More]

Why can't I read what I have written to the data socket server?

Category:DefaultRelease time:-0001-11-30Views:130

Hi, I have a problem with DataSocket: I open a socket and in a cycle I read from the socket and write a boolean "TRUE" to the socket. But reading from the socket I always get a "FALSE" value back. Monitoring the socket from a second VI[More]

Hot
Hello, I have a user that is sending a message to a email address and something is resolving the email address to the wrong address.  First of all, the email address in question is a mail contact on our system and is in the GAB. The SMTP email addres [More]
ging Superisory control toolkit the error is "if you have just converted to a new version of labveiw a new version of TAg engine may be required" how do i fix this error is there any upadate for fixing this error . the version i am currently usi [More]
Hi All I spent 3 hours importing my CD collection to itunes, but the songs arent named and the tracks arent in an album. I have gone to import artwork and nothing happens. I dont have the option of getting track names either. Any help please. Thanks [More]
I did a 10x upsize with SizerFixer SLR, and Lightroom will not generate a viewable thumbnail. The thumbnail looks like a grey negative. However, PSE3.0 and Windows viewer have no problem with the image. What gives?What file format...what did you do t [More]
Hi I have the A700, if I were to plug in an HDMI to VDI cable on the HDMI output and connect it to a second monitor, would I be able to have both monitors available for viewing, or can I only view one at a time? http://www.computercablestore.com/5_Me [More]
Hi guys, My Self-assembled PC was working fine for 11 mths, until 2 days ago when it just froze in POST, no video signal, and beeps... I did the standard component test as below, 1) PSU,CPU,Mobo = Looping 1 long beep (Asking for RAM?) 2) + 1 x ram = [More]
I just got a new E5 and was playing with some settings as well as Ovi maps. On ovi maps, I can see two figures on the bottom right corner, one is a counter for data usage and one looks like a phone signal with green and red bars. Now, I have it in of [More]
Hi all, When I install the OBIEE 11.1.1.6 64bit on Oracle Linux 6.2, it failed at creation domain. [2012-05-29T16:41:17.953+08:00] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 36] [ecid: 0000JUNkP6DFw000jzwkno1Fl8Qk00000R,0] Begining Oracle [More]
Hello Experts, We are using CRM 2007 Interaction Center Web Client and I would like to know how I can achieve the following: We need that an specific Date Type should be filled with the date and time of the moment in which the user set the status of [More]
Sometimes my JFrame forms open with only their border visible. The interior is transparent, showing the background. This also happens, but less often, with JOptionPanes. Whenever it does happen, I can minimize then restore the form and all is correct [More]