Sitemap

Amicuk Programming Answers

Thumbnails present but not populated with photo's

2015-10-11   Views:0

Advertisement

Help! Both the Events and Photo thumbnail boxes are all present but they don't include the photo's. When I open events all the photo boxes are visible - but empty. Trying to open a photo results in a "!" indicator. Over 6,000 images at stake, an

Help!
Both the Events and Photo thumbnail boxes are all present but they don't include the photo's. When I open events all the photo boxes are visible - but empty. Trying to open a photo results in a "!" indicator. Over 6,000 images at stake, any help appreciated.

The replay answer
Advertisement
Welcome to the Apple Discussions. The "!" means that the library has lost the file path to the original file. This happens when there has been an interruption to iPhoto while it is writing to it's database file, Library6.iPhoto. Moving, renaming files or folder inside the library package while in the Finder is another way you can get that indication. Try the three fixes below in order as needed:
1 - launch iPhoto with the Command+Option keys depressed and follow the instructions to rebuild the library. Select the first three options.
2 - rebuild the library using iPhoto Library Manager as follows:
Using iPhoto Library Manager to Rebuild Your iPhoto Library
1 -Download iPhoto Library Manager and launch.
2 -Click on the Add Library button, navigate to your User/Pictures folder and select your iPhoto Library folder.
3 - Now that the library is listed in the left hand pane of iPLM, click on your library and go to the File->Rebuild Library menu option
4 - In the next window name the new library and select the location you want it to be placed.
5 - Click on the Create button.
Note: It may take some time to create the new library if you have a lot of photos. Report back on how long it took and how many photos you have in the library so we can give other users an idea of how long it may take.
3 - start over with a new library and import the Originals folder from your original library as follows:
Creating a new library while preserving the Events from the original library.
Move the existing library folder to the desktop.
Open the library package like this.
Launch iPhoto and, when asked, select the option to create a new library.
Drag the Originals folder from the iPhoto Library on the desktop into the open iPhoto window.
This will create a new library with the same Events as the original library if you have the Finder checkbox unchecked in the Events preference pane.
TIP: For insurance against the iPhoto database corruption that many users have experienced I recommend making a backup copy of the Library6.iPhoto database file and keep it current. If problems crop up where iPhoto suddenly can't see any photos or thinks there are no photos in the library, replacing the working Library6.iPhoto file with the backup will often get the library back. By keeping it current I mean backup after each import and/or any serious editing or work on books, slideshows, calendars, cards, etc. That insures that if a problem pops up and you do need to replace the database file, you'll retain all those efforts. It doesn't take long to make the backup and it's good insurance.
I've created an Automator workflow application (requires Tiger), iPhoto dB File Backup, that will copy the selected Library6.iPhoto file from your iPhoto Library folder to the Pictures folder, replacing any previous version of it. It's compatible with iPhoto 08 libraries and Leopard. iPhoto does not have to be closed to run the application, just idle. You can download it at Toad's Cellar. Be sure to read the Read Me pdf file.

Go to See the other 5 answers

Thumbnails present but not populated with photo's

Category:DefaultRelease time:2015-10-11Views:130

Help! Both the Events and Photo thumbnail boxes are all present but they don't include the photo's. When I open events all the photo boxes are visible - but empty. Trying to open a photo results in a "!" indicator. Over 6,000 images at stake, an[More]

I recently moved all of my photos from one portable drive to a new and much larger one. I use LR 5 and and all of the folders now have a ? in their folder icon. The thumbnail is there but no actual photo. How do i reconnect them?

Category:DefaultRelease time:2015-10-11Views:130

i recently moved all of my photos from one portable drive to a new and much larger one. I use LR 5 and and all of the folders now have a ? in their folder icon. The thumbnail is there but no actual photo. How do i reconnect them? Jim Boehme [email pr[More]

I use an external HD (WD My Passport) to store my iPhoto photos.  When I backed these up on another EHD (WD My Passport Ultra), thumbnails, and a lot of the photos did not copy (show "!").  Now 1st HD says its on a locked volume?  What happened?

Category:DefaultRelease time:-0001-11-30Views:130

I use an external HD (WD My Passport) to store my iPhoto photos.  When I copied these up on another EHD (WD My Passport Ultra): thumbnails, and a lot of the photos did not copy (show "!").  Now 1st HD says its on a locked volume?  Why? Right bef[More]

When I drag a photo to the timeline on iMovie, a different photo appears.  I've tried recreating thumbnails, and also created the problem photos in a test library.

Category:DefaultRelease time:-0001-11-30Views:130

When I drag a photo to the timeline on i-Movie sometimes a different photo, or even a video appear and sometimes it is just a black screen.  I've tried recreating thumbnails, and even copied the problem photos into a test library, but still can't get[More]

How can you change the thumbnail selected for an Album in Photos?

Category:DefaultRelease time:2015-10-11Views:130

I'm having difficulty changing the photo that is automatically selected as the thumbnail on an iPad Air and iPad Mini.  How can I change this, and what parameter governs which photo is selected? There are a number of threads about changing the name,[More]

In iPhoto, the thumbnails do not match the real photo, they repeat often the same 15 photos over and over

Category:DefaultRelease time:2015-10-11Views:130

My iPhoto 9.3.2 (670..63) in Mountain Lion is repeating a grouping of thummnails whose photos when you click do not match.  I have called Apple Care and have reinstalled a new iPhoto library and still have the problem.  We did al this after the updat[More]

Iphoto shows correct thumbnail but does not show master photo or shows wrong master photo

Category:DefaultRelease time:2015-10-11Views:130

iPhoto has been working fine for me for 2 years.  But yesterday I started noticing problems with the photos when scrolling thru all the photos in an event. When viewing the event, I can see all of the correct thumbnails for the photos in the event. [More]

In iPhoto, I can see the thumbnails but not the full-size photos

Category:DefaultRelease time:2015-10-11Views:130

In iPhoto, I can see the thumbnails along the bottom but I can't see the full-size photos - I just see a black screen. What should I do?There are several possible causes for the Black Screen issue 1. Permissions in the Library: Back Up and try rebuil[More]

HT2638 Hi, My Iphoto (on Mavericks) shows me a thumbnail but actually it is another photo whan you open it up...any idea what the problem could be? big thanks!

Category:DefaultRelease time:2015-11-21Views:130

This has happened since my snow leopard update to be fair. I continuously mess up all of my "events" with photoes that shoul now be there due to this mistake. Anyone know something about it? Big thanks in advancegiven the time this problem has e[More]

Syncing thumbnails in library with deletion of photos from disk?

Category:DefaultRelease time:-0001-11-30Views:130

After I delete some photos directly from the disk, iPhoto's thumbnails still remain the same. Only when I try to open an image do I get a black alert box, implying that the original file is missing. Is there a way to automatically sync the library to[More]

No thumbnails appear in iweb media for photos

Category:DefaultRelease time:-0001-11-30Views:130

Back in Jan, this question was asked but I could not find the answer to this topic and it had a green star. Sorry to be redundant but this just happened. Could someone please help me out ? Thank you in advance. When I select media on iWeb, iWeb pulls[More]

Hot
Cant download previous purchases on my account. Bought them via my iphone, but when i try to sync it they dont come up and when i try to download them via my phone again it just doesnt work, and when i try to download them via a computer it just says [More]
As far as I can remember, I've always had this problem in Bridge.  All videos have horrible playback.  The video is choppy and stutters and the audio is not in sync.  It doesn't matter what format the video is in, although I have noticed that videos [More]
After the jelly bean update my Xperia got slow, I could not answer phone calls, the call log took so much time to appear , I have tried uninstalling external softwares , reseting the phone , nothing worked. Finally I have downgraded the phone follwin [More]
Please help me I just got this as a giftDownload the Users Guide. It will answer the questions. iPod touch User Guide iOS 6Read other 2 answers [More]
Hi experts, Now My requirement is get all contract condition data. If I don't want to create a new contract to get these condition data, I can use Function module 'PRICING' to get all condition data. But the question is the parameter COMM_ITEM_I is a [More]
Hi Experts, Scenario A > holds 100% in B, 10% in C, 5% in D B > holds 90% in C, 95% in D, 100 % in E, 1 % in F E > holds 99 % in F No shares are owned by parties outside the group. 1) Minority Interest In case like this will MI be accounted for? [More]
I bought a used T60.  I am used to using HP Pavilions where the Fn and Ctrl keys are in the opposite positions as on the T60, and I am having trouble retriaining my fingers. So i looked for info about how to swap them.  I understand KeyTweak doesn't [More]
Somehow I managed to do somthing to my site folder and only a handfull of the files are there. I reviewed all the folders at the system level and the structure and files all appear to be there. Manage sites looks OK How do I rebuild my site. Jim Nanc [More]
Hi all, First post in these forums.  I've been using ACR for years and have been using Photoshop CS5 for a few weeks with no problems.  I've now installed ACR 6.1... Here's the problem that is driving me nuts: when I apply a preset to an image, ALL s [More]
I am running into an issue with an Umbraco website. If I miskey the URL on a top level page, e.g. mysite.com/wrongpage I get an asp error. If I miskey it on a subpage, even if the top level page is incorrect too, I get my correct 404 error e.g. mysit [More]