Sitemap

Amicuk Programming Answers

Upgrading from weblogic 8.1 to 10gr3 facing problem with the Building

-0001-11-30   Views:1

Advertisement

Internal compiler error java.lang.NullPointerException at org.eclipse.jdt.internal.compiler.lookup.ReferenceBinding.binarySearch(ReferenceBinding.java:108)      at org.eclipse.jdt.internal.compiler.lookup.ParameterizedTypeBinding.getMethods(Parameter

Internal compiler error
java.lang.NullPointerException at org.eclipse.jdt.internal.compiler.lookup.ReferenceBinding.binarySearch(ReferenceBinding.java:108)
     at org.eclipse.jdt.internal.compiler.lookup.ParameterizedTypeBinding.getMethods(ParameterizedTypeBinding.java:542)
     at org.eclipse.jdt.internal.compiler.lookup.Scope.findMethod(Scope.java:1069)
     at org.eclipse.jdt.internal.compiler.lookup.Scope.getMethod(Scope.java:2072)
     at org.eclipse.jdt.internal.compiler.ast.MessageSend.resolveType(MessageSend.java:428)
     at org.eclipse.jdt.internal.compiler.ast.CastExpression.resolveType(CastExpression.java:460)
     at org.eclipse.jdt.internal.compiler.ast.LocalDeclaration.resolve(LocalDeclaration.java:187)
     at org.eclipse.jdt.internal.compiler.ast.AbstractMethodDeclaration.resolveStatements(AbstractMethodDeclaration.java:428)
     at org.eclipse.jdt.internal.compiler.ast.MethodDeclaration.resolveStatements(MethodDeclaration.java:195)
     at org.eclipse.jdt.internal.compiler.ast.AbstractMethodDeclaration.resolve(AbstractMethodDeclaration.java:402)
     at org.eclipse.jdt.internal.compiler.ast.TypeDeclaration.resolve(TypeDeclaration.java:1084)
     at org.eclipse.jdt.internal.compiler.ast.TypeDeclaration.resolve(TypeDeclaration.java:1165)
     at org.eclipse.jdt.internal.compiler.ast.CompilationUnitDeclaration.resolve(CompilationUnitDeclaration.java:366)
     at org.eclipse.jdt.internal.compiler.ast.CompilationUnitDeclaration.analyseCode(CompilationUnitDeclaration.java:102)
     at org.eclipse.jdt.internal.compiler.Compiler.process(Compiler.java:626)
     at org.eclipse.jdt.internal.compiler.Compiler.compile(Compiler.java:392)
     at org.eclipse.jdt.internal.core.builder.AbstractImageBuilder.compile(AbstractImageBuilder.java:362)
     at org.eclipse.jdt.internal.core.builder.BatchImageBuilder.compile(BatchImageBuilder.java:174)
     at org.eclipse.jdt.internal.core.builder.AbstractImageBuilder.compile(AbstractImageBuilder.java:299)
     at org.eclipse.jdt.internal.core.builder.BatchImageBuilder.build(BatchImageBuilder.java:59)
     at org.eclipse.jdt.internal.core.builder.JavaBuilder.buildAll(JavaBuilder.java:269)
     at org.eclipse.jdt.internal.core.builder.JavaBuilder.build(JavaBuilder.java:177)
     at com.bea.wstudio.javabuilderx.JavaBuilderX.build(JavaBuilderX.java:66)
     at org.eclipse.core.internal.events.BuildManager$2.run(BuildManager.java:624)
     at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
     at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:166)
     at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:197)
     at org.eclipse.core.internal.events.BuildManager$1.run(BuildManager.java:247)
     at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
     at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:249)
     at org.eclipse.core.internal.events.BuildManager.basicBuildLoop(BuildManager.java:302)
     at org.eclipse.core.internal.events.BuildManager.build(BuildManager.java:334)
     at org.eclipse.core.internal.events.AutoBuildJob.doBuild(AutoBuildJob.java:137)
     at org.eclipse.core.internal.events.AutoBuildJob.run(AutoBuildJob.java:235)
     at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
     Utilities/src/com/att/edb/dppco/util     ErrKey.java     line 0     1247660099328     104158
i am using jdk160_05 as standard VM
checked with jrockit_160_05 as an Standard VM, when building i am getting the same above error
can anybody help me on this

The replay answer
Advertisement
hmm so are you compiling your old 8.1 code in WLS 10.3 and getting the error during compilation?
I found similar issue reported before:-
Re: Running Eclipse with Jrockit issues

Go to See the other 8 answers

Upgrading from weblogic 8.1 to 10gr3 facing problem with the Building

Category:DefaultRelease time:-0001-11-30Views:130

Internal compiler error java.lang.NullPointerException at org.eclipse.jdt.internal.compiler.lookup.ReferenceBinding.binarySearch(ReferenceBinding.java:108)      at org.eclipse.jdt.internal.compiler.lookup.ParameterizedTypeBinding.getMethods(Parameter[More]

I'm using an iPhone 4 after upgrading to iOS 5 i'm getting an error 1635 now i'm facing problems syncing my contacts and facing many problems, i have restored my iPhone but still i'm getting the same error

Category:DefaultRelease time:2015-10-11Views:130

i'm using an iPhone 4 after upgrading to iOS 5 i'm getting an error 1635 now i'm facing problems syncing my contacts and facing many problems, i have restored my iPhone but still i'm getting the same errorDid you check your security software settings[More]

Hot mail is not working after firefox upgrade. I am using Firefox 12.0. I did not have issue with hotmail, but I am facing problem this week .

Category:DefaultRelease time:2015-10-11Views:130

I am using Firefox 12.0. I did not have issue with hotmail, but I am facing problem this week after firefox upgrade. After entering login the page freeze. I am not able to continue. I reviewed the thread. I am not using Foxit. I reviewed hot mail for[More]

How to upgrade  from  weblogic  10.3.5 to  10.3.6

Category:DefaultRelease time:2015-10-11Views:130

Hello   I have been deployed  three  Weblogic  domains  across  two Windows servers  2008 R2,  one  domain  host  oracle business intelligence  publisher,  one domain  host  JEE enterprise applications and one domain  will  host Oracle form and Oracl[More]

Upgrade from Weblogic 10.3.1 to 10.3.3    Issues

Category:DefaultRelease time:2015-10-11Views:130

Hi We are in process of migrating/upgrading from Weblogic server 10.3.1 to 10.3.3. A heavily distributed application is being migrated with high volume transaction on clustered environment. Have anybody experienced any issues/ concerns when migrating[More]

NoClassDefFoundError after upgrading to Weblogic 8.1 sp2 to sp4

Category:DefaultRelease time:2015-10-11Views:130

Hi , I have stuck in a problem where my application is using jco.jar file for SAP integration to my java application. I have a java class "BAPI_IncentiveReport" in which it calls "addClientPool" that is in JCO class in jco.jar file but[More]

Upgrading the weblogic portal from 9.2 to 10.3

Category:DefaultRelease time:-0001-11-30Views:130

Can you please help me on the list of activities to be carried out in upgrading the weblogic portal from 9.2 to 10.3If you are currently running Mac OS 9.2.x from your hard drive, you are already doing it. You should be able to download and run the a[More]

I am facing problem while reading values from properties file ...i am getting null pointer exception earlier i was using jdeveloper10g now i am using 11g

Category:DefaultRelease time:2015-10-11Views:130

i am facing problem while reading values from properties file ...i am getting null pointer exception earlier i was using jdeveloper10g now i am using 11ghi TimoHahn, i am getting following exception in JDeveloper(11g release 2) Studio Edition Version[More]

Facing problem in sync from itunes - windows 7 64bit

Category:DefaultRelease time:2015-10-11Views:130

    Hi, I've been using iphone 4 for more than a year , i updated to ios5.0.1 and had no issued in it , but later on started facing problem in syncing my phone with itunes since i started  using windows 7- 64bit , then i thought i might need to upgra[More]

Facing problem in integrating my custom jsp with the workflow engine

Category:DefaultRelease time:2015-10-11Views:130

Hi, I am using Jdeveloper 11.1.1.6.0 for BPM 11g implementation on my Application.I have Weblogic Server 10.3 Installed and configured the domain. Also the server is up and running. I am trying to create workflow and wants to integrate it with my cus[More]

Facing Problem in getting WSRP folder inside Portal_Home/j2ee folder.

Category:DefaultRelease time:-0001-11-30Views:130

Hi friends, Currently i am facing problem in getting "WSRP" folder inside Portal_Home/j2ee folder.Let me explain in detail.While installing oracle portal i tried to upgrade from 10.1.2 to 10.1.4.Where mura.bat was executed fine.I got the message[More]

Hot
Hi, Due to business rules I got the following requirement, I'd like to get advice or second opinions please: Instead of showing 200 lines we want to show 1 line in the invoice summarizing the job done. The requirement is: The invoice should summarize [More]
hi all       when loading to psa," Error in generating program" occurs .can anybody suggest the possible solution. thank you pradeephi activate the Tranfser rules with this program RS_TRANSTRU_ACTIVATE_ALL and reload bhaskarRead other 6 answers [More]
I'm on the choose a user screen and when I enter the password the screen goes white then returns to choosing a user. The system is rebooting differently when I tried turning off then back on, the pinwheel screen has a progress bar and it takes minute [More]
I activated Server 2012 OEM yesterday on a new server and now find that I have delete the raid 5 and start over again. Will i be able to activate it again after reinstall?Yes, you should be ok.  Please refer to the following document, look at OEM act [More]
Hi! Lion seems fine for me ... but I can't see the drive capacity / free space which was previously at the bottom of each finder window. Any ideas where it is?  I can't see an option to turn it on, anywhere! Many thanksUmmm... View menu --> Show path [More]
Hello, i am interested in the report layouts in the new apex 3.0 version. Does anybody have experiences with that? Is it true, that I can edit the xml file only with a licensed version of XML publisher and not the desktop version? By the way is ther [More]
Hi, I am able to generate dynamic columns in table using datamodel. Please guide how to place values in that table using datamodel as shown below. 2009 2008 2007 X 10 20 30 X 30 40 40 Y 20 10 2 Z 1 2 1 Thanks in advanceHi HimSSS, you already have gen [More]
Hi I am setting up SAP CM for a client running SAP ERP 6.0 release 603. We want to update SAP Treasury into SAP CM and have succeded in getting some expected cash flows into the cash position report from Treasury. The issue is however that when we wa [More]
Do I define all the servlets in the one web.xml or one web.xml per servlet?web.xml is per your webapplication,one for each application. All the servlets of your particular webapplication need to be configured in the web.xml of your webappRead other 2 [More]
Anywone knows how to delete a record from a record group, i have this code below on the trigger KEY-DELREC, every time i delete a record this code is execute. The problem here is that i whant to delete a row in a record group but , i can't use the fu [More]