Sitemap

Amicuk Programming Answers

X86_64 install error libthread.so

2015-10-11   Views:2

Advertisement

All i have an X86_64 suse 9.1 and i am trying to install oracle 10.2.0 on my server i get this error in the installer log INFO: ./x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../libpthread.so when s

All i have an X86_64 suse 9.1 and i am trying to install oracle 10.2.0 on my server i get this error in the installer log
INFO: ./x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../libpthread.so when searching for -lpthread
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../libpthread.a when searching for -lpthread
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: cannot find -lpthread
INFO: collect2:
INFO: ld returned 1 exit status
INFO: make: *** [ctxhx] Error 1
[pre]
Info is
[pre]
$ uname -a
Linux test1 2.6.5-7.267-smp #1 SMP Wed Jun 21 10:50:51 UTC 2006 x86_64 x86_64 x86_64 GNU/Linux
[pre]
gcc
[pre]
$ gcc -v
Reading specs from /usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/specs
Configured with: ../configure enable-threads=posix prefix=/usr with-local-prefix=/usr/local infodir=/usr/share/info mandir=/usr/share/man enable-languages=c,c++,f77,objc,java,ada disable-checking libdir=/usr/lib64 enable-libgcj with-gxx-include-dir=/usr/include/g++ with-slibdir=/lib64 with-system-zlib enable-shared enable-__cxa_atexit x86_64-suse-linux
Thread model: posix
gcc version 3.3.3 (SuSE Linux)
[pre]
I see in the make.log that it is uing m32 on the gcc compile should it be doing this ?
[pre]
gcc -m32 -o ctxhx -L/data/oracle/product/10.2.0/gfmis/ctx//lib32/ -L/data/oracle/product/10.2.0/gfmis/lib32/ -L/data/oracle/product/10.2.0/gfmis/lib32/stubs/  /data/oracle/product/10.2.0/gfmis/ctx/lib/ctxhx.o -L/data/oracle/product/10.2.0/gfmis/ctx/lib/ -ldl -lm -lctxhx -Wl,-rpath,/data/oracle/product/10.2.0/gfmis/ctx/lib -lsnls10 -lnls10  -lcore10 -lsnls10 -lnls10 -lcore10 -lsnls10 -lnls10 -lxml10 -lcore10 -lunls10 -lsnls10 -lnls10 -lcore10 -lnls10  `cat /data/oracle/product/10.2.0/gfmis/lib/sysliblist`
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../libpthread.so when searching for -lpthread
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../libpthread.a when searching for -lpthread
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: cannot find -lpthread
collect2: ld returned 1 exit status
make: *** [ctxhx] Error 1
[pre]                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               

The replay answer
Advertisement
Hi,
I have installed the Oracle 10g on a RHEL 4 update 4 box, and have the same problem:
$ gcc -m32 -o ctxhx -L/home/oracle/oracle/product/10.2.0/db_2/ctx//lib32/ -L/home/oracle/oracle/product/10.2.0/db_2/lib32/ -L/home/oracle/oracle/product/10.2.0/db_2/lib32/stubs/ /home/oracle/oracle/product/10.2.0/db_2/ctx/lib/ctxhx.o -L/home/oracle/oracle/product/10.2.0/db_2/ctx/lib/ -ldl -lm -lctxhx -Wl,-rpath,/home/oracle/oracle/product/10.2.0/db_2/ctx/lib -lsnls10 -lnls10 -lcore10 -lsnls10 -lnls10 -lcore10 -lsnls10 -lnls10 -lxml10 -lcore10 -lunls10 -lsnls10 -lnls10 -lcore10 -lnls10 `cat /home/oracle/oracle/product/10.2.0/db_2/lib/sysliblist`
/usr/bin/ld: skipping incompatible /usr/lib64/libpthread.so when searching for -lpthread
/usr/bin/ld: skipping incompatible /usr/lib64/libpthread.a when searching for -lpthread
/usr/bin/ld: cannot find -lpthread
collect2: ld returned 1 exit status
Here are my glibc packages installed that are the sollution of Suse platform, but does not work at my Red Hat Enterprise:
$ rpm -qa|grep glibc-devel
glibc-devel-2.3.4-2.25
$ rpm -qa|grep glibc-32
glibc-32bit-9.3-7.1
Does anyone have any idea ?
Thanks.
Reu.

Go to See the other 8 answers

X86_64 install error libthread.so

Category:DefaultRelease time:2015-10-11Views:130

All i have an X86_64 suse 9.1 and i am trying to install oracle 10.2.0 on my server i get this error in the installer log INFO: ./x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../libpthread.so when s[More]

Virt-install: error: no such option: --usbtablet ??

Category:DefaultRelease time:-0001-11-30Views:130

Hi I'm trying to install full virtualized guest domain with installation media and getting the following error: ailed:<Exception: failed:<Exception: virt-install hvm usbtablet name=356_LVMtest ram=256 vcpus=1 mac=00:16:3E:23:1B:21 bridge=xenbr0 file[More]

Install error messages

Category:DefaultRelease time:2015-10-11Views:130

I get the following error messages when installing CS6. Anybody have any idea if this is a problem, or if these are components of the various programs that I will never need? Exit Code: 6 Please see specific errors and warnings below for troubleshoot[More]

Install error "unable to locate folder for token UserDocuments"

Category:DefaultRelease time:2015-10-11Views:130

I'm trying to install a trial of CS5.5 Design Premium and I keep getting this error. I've been working on it for the past two days and I can't find anything useful on the kb or forums. Installer said on exit: (full install log below) Exit Code: 7 ---[More]

Hello, I trying to update Adobe Creative Cloud Desktop but there is an error after instalation (error code: 50)

Category:DefaultRelease time:2015-10-11Views:130

Hello, I trying to update Adobe Creative Cloud Desktop but there is an error after instalation (error code: 50) Uninstalling and installing again - nothing change.Hi slawek, Please refer to the thread below where this issue has been discussed: Error[More]

Itunes install error message - program not found ...x64/difxinst64.exe

Category:DefaultRelease time:2015-10-11Views:130

itunes install error message - program not found ...x64/difxinst64.exe no problems with ITunes on Dell Inspiron Windows 7 until yesterday.  ITunes version 11.0.2.  iphone won't connect stating required software is not installed.  uninstall and instal[More]

Install error #1620 PrPro Windows Vista Home Premium

Category:DefaultRelease time:2015-10-11Views:130

Install error 1620  when attempting to install CS4 "This installation package could not be opened"  (for each component of the software package).   Windows Vista Home Premium 32 bit, Intel i7 processor.   Unable to install any components of PrPr[More]

Windows 7 64bit Install error microsoft.vc80.CRT,type="win32",version="8.0.50727.4053",publicKeyToken="1fc8b3 b9a1e8e3b",processorArchitecture="amd64"

Category:DefaultRelease time:2015-10-11Views:130

How do i fix this install error.  Very fustrating. Not sure if this is the ideal solution but worked just fine. I simply reinstalled Windows 7 using pre-delivered Microsoft functionality. Upon sucessful reinstall Itunes latset version worked just fin[More]

Windows 7 install error 0x80300024

Category:DefaultRelease time:2015-10-11Views:130

Mac Pro with 4 internal hard drives. My primary startup drive (in bay #1) has 10.5 on it. Wanted to install Windows 7, so needed Snow Leopard's Bootcamp to do that. The fourth hard drive in the machine was new, so wiped that, installed Snow Leopard,[More]

Administrative installing error

Category:DefaultRelease time:2015-10-11Views:130

Ok for the past week I've been trying to upgrade or uninstall adobe air. I'm running on a windows vista SP2 32-bit. The error I receive when I try to upgrade,uninstall or install is "An error occurred while installing Adobe AIR. Installation may not[More]

Adobe CS5.5 Production Premium Install Errors and Other Issues

Category:DefaultRelease time:2015-10-11Views:130

Hi, I just  installed Adobe CS5.5 Production Premium on my computer and had some  errors pop up at the end of installation.  I  will paste the summary below.   I've tried to install Procction Premium a couple of times.  I've used  the Adobe Cleaner T[More]

Hot
Hi All        i want ur's guidance on calling a Report Transaction Code (T.Code) from with in the  BSP.        Like T.Code MB5B is for Stock on Posting date . i want to call it in BSP with in the frame. please guide me . Regards SachinHi   I have onl [More]
I don't know much about Macs and I know even less about Mac laptops! Someone told me that the macbook (Intel based??) would be the best mac laptop to use with Final Cut Pro 4. Could someone tell me if this IS my best option or if I should be looking [More]
I just finished my first Arch installation. I'm as green as they come, so your help and patience is appreciated! Situation: I want to connect using my workplace's ethernet to the internet, so I can download a GUI. I've figured out how to assign a sta [More]
hi all  I'm  trying to find out if there is an extension for safari to show me which tab is active  if i open a lot of tabs some of them start playing audio and it's frustrating trying to find the pages with the active audio.  if anyone knows how to [More]
Dear friends, I've been writing a report in which I have the date field on selection-screen. By default I have been displaying the system date on the selection-screen. The reqiurement is that the user cannot execute the code for a date in past (less [More]
Hello everyone! My mid-2012 MacBook Pro 15' recently started showing a message in a small box - unnounced - that asks, "Do you want to restart your Mac?" with a 1 minute countdown timer in effect. What is this? I have never seen this before. It [More]
<p>Hi,</p><p> </p><p>I have recently upgraded to Hyperion Reports 7.2.  I'mrunning on Essbase 6.5.42.  Our old version of HyperionReports was 2.6, and I always had problems running reports usingthe batch scheduler, so never u [More]
Hi, i created a portal service from a wsdl. i configured in the j2ee the proxy forinternet access. Now when i'm trying to access this portal service i receive the following error: 0}#1#com.sap.engine.services.webservices.jaxm.soap.accessor.NestedSOAP [More]
Hi, I need to consume web services of SIebel CRM On Demand with PHP. I reading the documentation about CRM but this have examples with C#. In the documentation i need first loggin in the CRM, but i dont know how connect from PHP. Please Can you give [More]
My problem is that I cannot save my document to pdf using  cs5 presets as i was able to do in cs4. This is very disturbing as I just finished two newsletters, 40pages and 20 pages and cannot get them to my printer as pdfs. I tried opening them in cs4 [More]