Sitemap

Amicuk Programming Answers

XML data via JS not showing in I.E.?

2015-10-11   Views:0

Advertisement

Hi there, I'm using Javascript to get the xml data and display it on the XHTML page. This works fine in all the latest versions of Firefox, Chrome, Safari and Opera....but as per usual not in Internet Explorer. UPDATE: forgot to mention.....I'm testi

Hi there,
I'm using Javascript to get the xml data and display it on the XHTML page.
This works fine in all the latest versions of Firefox, Chrome, Safari and Opera....but as per usual not in Internet Explorer.
UPDATE: forgot to mention.....I'm testing this from my machine and not live.   Could this be a reason why it's not working on I.E. because the files are on my computer and not on a server???
Any advice greatly appreciated! HTML Code below...
<div id="testimonials">
                <h1>Testimonials</h1>
                <script type="text/javascript">
                                if (window.XMLHttpRequest)
                                  xhttp=new XMLHttpRequest();
                                else // Internet Explorer 5/6
                                  xhttp=new ActiveXObject("Microsoft.XMLHTTP");
                                xhttp.open("GET","resources/testimonials.xml",false);
                                xhttp.send("");
                                xmlDoc=xhttp.responseXML;
                                var x=xmlDoc.getElementsByTagName("testimonial");
                                for (i=0;i<x.length;i++)
                                  document.write("<p>");
                                  document.write(x[i].getElementsByTagName("text")[0].childNodes[0].nodeValue);
                                  document.write("</p>");
                                  document.write("<p>");
                                  document.write(x[i].getElementsByTagName("name")[0].childNodes[0].nodeValue);
                                  document.write("</p>");
                        </script>
      </div> <!-- END of DIV Testimonials -->
Cheers!

The replay answer
Advertisement
Thanks for the attachment, I'll try and make some sense of it- although I'm not very good with JS!
I think it's the XML HTTP Request part that isnt working.
It all works fine in all the major browsers except I.E.?
Not sure if you've seen my update but does it matter that I'm testing the site from my machine and not on a server?  Does I.E. expect all the files (or the XML file at least) to be sitting on a server to make the XMLHttpRequest() work?

Go to See the other 4 answers

Using a SQL data source and XML data source in the same template

Category:DefaultRelease time:2015-10-11Views:130

I am trying to develop a template for the Request for Quote report generated in Apps 11.5.10. I have loaded the data from the XML output into the template, but I am missing one field - I need the org_id from the po_headers table. Is it possible to us[More]

XML data 32K into CLOB

Category:DefaultRelease time:2015-10-11Views:130

Hi all, I am trying to use UTL_FILE.PUT_LINE to output an XML file. This xml file is the result of a select query. Hence converting the result of the select query into xml format using dbms_xmlgen.getxml and storing it in a variable. But the resultan[More]

How i can transfer XML data from internet to SAP R/3?

Category:DefaultRelease time:2015-10-11Views:130

Hi all, I have an issue to catch data from internet (perticular website) in xml format and i want to update that xml data format into SAP R/3 database. so how i can do that? Can I do directly or i should use any third party tools?Hi Deepak,     Refer[More]

DataGrid does not display XML data

Category:DefaultRelease time:2015-10-11Views:130

Hello, and thanks for reading this... I am having a problem displaying XMLList data in a DataGrid. The data is coming from a Tree control, which is receiving it from a database using HTTPService. The data is a list of "Job Orders" from a MySQL d[More]

Edit/add XML data in BI Publisher

Category:DefaultRelease time:2015-10-11Views:130

Hi I have a java program that is generating an XML file that I am using as input for my BI publisher for PO report. However, I want to add some extra information(location addresses corresponding to location id) that is not there in the XML and I cann[More]

Regrouping the XML data source in BI Publisher

Category:DefaultRelease time:2015-10-11Views:130

Hello, We have a requirement in BI Publisher to develop a template accessing the data from different sources (data sets) and need to regroup the whole data by a field which exists in all the data sets. Below is the sample example of the source file <[More]

Tranferring XML data to the B1 System

Category:DefaultRelease time:2015-10-11Views:130

Hi, Iam very new to the B1 system.. Iam looking to transfer the data from the XML file to the B1 system. to make it clear, the requirement is i have a purchase order coming from one system and it is saved in the server..the data in the XML file will[More]

Convert XML data to byte array...

Category:DefaultRelease time:2015-10-11Views:130

Hello All, In my application, i have an XML file and the corresponding XSD file. This XML file is having some date, which i want to convert into an byte[] and then save it in a file.  How i can convert the XML data in the byte[]? Here as an example o[More]

How do I use the Session State to manage bind variables & download xml data

Category:DefaultRelease time:2015-10-11Views:130

I have a Report Query with more than 30 queries; many have bind variables in them. I'd like to create sample xml so that I can develop my word templates. When I try to download the XML data Source for Layout, it doesn't ask for the bind variable valu[More]

XML Data ( View Total exist in a different query)

Category:DefaultRelease time:2015-10-11Views:130

Hi, This is a sample of my xml data : <TEST_COMP> - <LIST_G_Q1> - <G_Q1>   <Q1_ITEM_ID>61</Q1_ITEM_ID>   <TOT>13754492</TOT>    </G_Q1> - <G_Q1>   <Q1_ITEM_ID>62</Q1_ITEM_ID>   <TOT>1[More]

How to create a report using XML data source from Crystal Report Designer

Category:DefaultRelease time:2015-10-11Views:130

Hi, Iu2019m having Crystal Report Designer XI R2 SP4. Iu2019m trying to create a report using XML data source stored on disk. This is a customer order report and the xml is structured in such a way that it has an order details header part (master) an[More]

Hot
Hi When we are processing MIGO for a PO we are getting error message GL ac so and so in not consistent and if I double click on that message below detial message is getting displayed: This line item carries the "W" posting line identification. T [More]
I created a form in LiveCyle using Pro 9, the form was created for an employer who had to buy Pro X so I was upgraded to Pro X.  Here are the issues I am having, This form was the first time I have ever created a form and I have never used Java Scrip [More]
Since recently upgrading to Firefox 4.0 I have been hearing a loud 'ping' type sound when certain websites are visited eg Google Mail. This is a new and unwelcome distraction! How can I stop it?Try this: EDIT: * Goto about:config * Look for print.pri [More]
Hi All, Is there any best practices guide for development purpose in design studio? I am facing performance issues when I increase the count of data sources (alias in my case) in my application merely from 2 to 3. There is a considerable time lag in [More]
Hi, I'm extremely new to Java and need to read and parse a text file and generate a new text file with modifications as follows: 1. Ignore and rewrite comments 2. Ignore and rewrite compiler commands 3. (a) Modify function prototypes be removing thei [More]
I have an 11g database on red hat linux and when I initially log into the machine as the Oracle user and do and export ORACLE_SID when I do a sqlplus / as sysdba it doesnt pick up the the database I specified(in this situation lumtest). If I do an . [More]
Hi All, I've got an OS X server that for some reason ( probably due to me pratting around) has decided not to have a working server admin prog. I can fire up the client program and point it at any of the IP addresses that the server is listening on a [More]
Hi all, Each time I run the Solaris installation CD,whatever the CD version(CD1 of 2 or Sol8 installion),I'm getting these following errors,this occurs just after the hardware scan start running: "error : 64 PCI bit len unsupported" and then: &q [More]
I have an issue with a single user account on a single computer at a client's place of business. When this user tries to print a PDF document, any graphics in the document come out very fuzzy or solid black. If this user logs onto the same computer a [More]
Apple Time Capsule working with Windows 7 PC will not work when modem is connected directly to the Time Capsule.  Only when a Cisco Linksystem is connnected inbetween the modem and the Time Capsule.Sorry but it needs much more specific info than this [More]